incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "christofer.dutz@c-ware.de" <christofer.d...@c-ware.de>
Subject AW: AW: AW: AW: Compiler Arguments
Date Thu, 01 Nov 2012 21:35:01 GMT
Am I understanding you correctly, that the handling of "-compiler.locale" is correct that way,
but the "-metadata.language" should probably only contain the first segment (In this case
" es_MX")?
Sounds sensible. Think I'll have a look at why this is some times generated.

@Mike ... I get failures about every 10 runs of the entire Testsuite (And yes ... having to
run it that often really sucks ... but I want to have my new FDKs up and running)

By the way ... I did do quite some work on the Flexmojos6 and FDK Generator on the last few
days and I think I might be able to finish FM6 and the new Flex FDKs before going zo the Apache
Con Europe :-) (See you there?)

Chris




-----Urspr√ľngliche Nachricht-----
Von: Alex Harui [mailto:aharui@adobe.com] 
Gesendet: Donnerstag, 1. November 2012 21:57
An: flex-dev@incubator.apache.org
Betreff: Re: AW: AW: AW: Compiler Arguments




On 11/1/12 1:17 PM, "christofer.dutz@c-ware.de" <christofer.dutz@c-ware.de>
wrote:

> Nope,
> 
> This would be the case if you wanted to add 3 different locales.
> If you define es_MX,es_ES,en_US this is more a locale-chain (I reverse 
> learned this from the unit-test code.
Hmm, is there really a difference from in the SDK code-paths for this?  I didn't think there
was, but I'm not the expert on locales.

Anyway, I want to point out your error is not in the locale handling.  The arguments to -locale
look like they are being handled correctly, but somehow, the same list ends up in -metadata.language.
 How is that happening?  If it is automatically being set up by something, that might need
to be changed to create a single string.

--
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message