incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Schmalle <apa...@teotigraphix.com>
Subject Re: [Falcon] build not finding playerglobal.swc
Date Wed, 28 Nov 2012 17:51:48 GMT
So does this mean I have to run the installer for it to work now?

I just tried adding the folder temporarily into the dist folder ,  
reran the build and got;

set.support.swc.available:
support.swc:
      [echo] Building support.swc
     [compc] Loading configuration file  
C:\Users\Mike\Documents\svn\apache\flex\falcon\trunk\compiler\generated\dist\sdk\frameworks\flex-config.xml
     [compc] Loading configuration file  
C:\Users\Mike\Documents\svn\apache\flex\falcon\trunk\compiler\dist\flex\frameworks\projects\support\framework-config.xml
     [compc] Apache Flex compc (Component Compiler)
     [compc] Version 4.9.0 build 0
     [compc] Copyright 2012 The Apache Software Foundation.
     [compc]  
C:\Users\Mike\Documents\svn\apache\flex\falcon\trunk\compiler\generated\dist\sdk\frameworks\flex-config.xml(65):
Error: unable to open  
'{playerglobalHome}/11.1/playerglobal.swc'
     [compc]       </external-library-path>



Mike



Quoting Alex Harui <aharui@adobe.com>:

> I think I had to point the Falcon build to an "installed Apache Flex SDK"
> (created by Om's installer) not a build from SVN/sources because our default
> sources point to an external playerglobal.swc.
>
> BTW, one of my first things to change in Falcon is its need to copy the SDK.
> I had it working to point to the Apache Flex source builds, but that seemed
> to get lost in the donation.
>
>
> On 11/28/12 9:40 AM, "Michael Schmalle" <apache@teotigraphix.com> wrote:
>
>> Hi,
>>
>> I had to reformat my computer, thus reinstall and build all the apache
>> flex libraries.
>>
>> I have done everything I did in the last run, when I tried to build
>> the falcon compiler after I built the sdk I got;
>>
>> Could not find file
>> ...\svn\apache\flex\falcon\trunk\compiler\generated\dist\sdk\frameworks\libs\p
>> layer\11.1\playerglobal.swc to
>> copy.
>>
>> Did something change where the sdk build does not copy that file
>> anymore? If so, how do we change the build of falcon to find it
>> correctly?
>>
>> Mike
>
> --
> Alex Harui
> Flex SDK Team
> Adobe Systems, Inc.
> http://blogs.adobe.com/aharui
>
>

-- 
Michael Schmalle - Teoti Graphix, LLC
http://www.teotigraphix.com
http://blog.teotigraphix.com


Mime
View raw message