incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Smith <gosm...@adobe.com>
Subject RE: [FALCON] Setting up unit tests correctly
Date Tue, 13 Nov 2012 22:43:09 GMT
Sorry, I forgot to make some 'ant' target create it. Can you do that? If not, I'll try to do
it on Friday.

- Gordon


-----Original Message-----
From: Michael Schmalle [mailto:apache@teotigraphix.com] 
Sent: Tuesday, November 13, 2012 2:39 PM
To: flex-dev@incubator.apache.org
Subject: Re: [FALCON] Setting up unit tests correctly

Ok, this was a serious brain cramp;

The problem was obvious after I stepped through the code 4 more times.  
The "temp" directory in the compiler.tests folder was not created, so the error was just that
the temp file had an invalid path.

On that note, Gordon, is this something you over looked in your setup?  
Or are developers supposed to create the temp directory manually?

Mike


Quoting Michael Schmalle <apache@teotigraphix.com>:

> Hi,
>
> I'm having trouble getting the unit tests working for falcon.
>
> I have the whole framework built (ran mustella), built the falcon SDK.
>
> The problem I am facing is I get an IOException;
>
>     [junit] java.io.IOException: The system cannot find the path specified
>     [junit] 	at java.io.WinNTFileSystem.createFileExclusively(Native Method)
>     [junit] 	at java.io.File.checkAndCreate(Unknown Source)
>     [junit] 	at java.io.File.createTempFile(Unknown Source)
>
> Basically it seems like Eclipse is telling me it can't create the Temp 
> MXML file. I am an administrator on Windows 7. I have never had this 
> problem in Eclipse before.
>
> Does anybody have any idea what's going on?
>
> Did I see in some past post Cyrill having a setup list?
>
> --
> Michael Schmalle - Teoti Graphix, LLC
> http://www.teotigraphix.com
> http://blog.teotigraphix.com
>
>

--
Michael Schmalle - Teoti Graphix, LLC
http://www.teotigraphix.com
http://blog.teotigraphix.com


Mime
View raw message