incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Om <bigosma...@gmail.com>
Subject Re: [VOTE] Release InstallApacheFlex 1.0 - RC2
Date Tue, 11 Sep 2012 20:00:51 GMT
On Tue, Sep 11, 2012 at 8:57 AM, Carol Frampton <cframpto@adobe.com> wrote:

> +.9 - would prefer to see my first 3 items under 2. fixed
>
> 1. I just updated build.xml (and the README to reflect the change) so that
> FLEX_HOME can be set as an environment variable.  You can chose to take
> this change or not.
>
> If FLEX_HOME is not set with -DFLEX_HOME=/path/to/flex/sdk on the ant
> command line
>         use the environment variable, if it exists. Else if windows, use
> FLEX_HOME_WIN
>         else use FLEX_HOME_MAC, which are both defined in build.properties.
>
> Some folks are having issues with ANT not recognizing the env. variables.
I am inclined to just remove this option since:
a.  It is really not a requirement to make this release
b.  There are two other ways to set these variables (using the command line
and via modifying build.properties)



> 2.  When testing the installer I noticed the following.
>
>
> - On the License Agreement page, I can click, "I Agree, Install" without
> reading any of the licenses or even seeing which license applies to which
> component.
>

This is a feature.  It was discussed here on the list [1] and approved via
lazy consensus.


> - The Adobe embedded font support is listed as Adobe Fontswf utility which
> isn't really accurate.  I might want embedded font support but care less
> about the utility and I wouldn't know to install this component.
>

I am not following you.  What should I change to fix this issue?


> - The version in sdk-installer-config.xml is 1.0.1 but the version in my
> log was Version 1.1(mac).
>

The version mismatch is a pretty serious problem.  Will fix this.

The next line in the log was "action"???
>

 Will fix this.


>
> - Why is the Disclaimer button so light?
>

Will fix this.

>
>
> 3. README section on "How to build the installer using Adobe Flash Builder
> (or any other IDE)".  The issue I have with this section is that if I
> follow the instructions I don't have a built installer so the section did
> not tell me how to build the installer using FlashBuilder.  In the
> previous section, "How to build the installer using ANT (no Flash Builder
> or any other IDE required)", if I follow the instructions, I end up with a
> built installer.
>

I see your point.  I will change the section heading to:  "How to set up
this project in Flash Builder/other IDEs".  Compiling/building a Flex
project using Flash Builder is outside the scope of this README.

>
> Carol
>
>
[1] http://markmail.org/message/tdzecrzwu7sfw5t4

Thanks,
Om

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message