incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <>
Subject Re: Getting Mustella to work.
Date Tue, 28 Aug 2012 15:21:44 GMT

On 8/28/12 8:12 AM, "Carol Frampton" <> wrote:

> On 8/28/12 9 :32AM, "Peter Ent" <> wrote:
>> I just ran tests/components/Application (without -createImages) and
>> received 274 (not 273!) passes. I will update the wiki this number.
>> Personally, I find Mustella frustrating in that it gives me inconsistent
>> passes and fails. You would think that each time you run it it would give
>> you the same result. I don't know why it does not always do that and we
>> need to figure this out. Alex might know or at least be able to explain
>> the behavior.
> If you are on the same platform, most of the time it is because of timing
> diffs and poorly written or incorrectly written tests.  The test could be
> waiting on the wrong event so it proceeds before it really should.  Or
> rather than figuring out the right event to wait on it just has a pause
> (which is generally not a good thing to do) and it might not be long
> enough.
That would affect pass vs fail, but shouldn't affect the total tests run.

We also want to know what tests are failing (without using -createImages)
and why.  That way we can better identify whether folks are having
configuration issues, or there are bad tests, or there are platform

Alex Harui
Flex SDK Team
Adobe Systems, Inc.

View raw message