incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Rovira <carlos.rov...@codeoscopic.com>
Subject Re: Mustella Test Repairs
Date Mon, 27 Aug 2012 14:35:11 GMT
Hi Peter,

yes, I'm fully synchronized with develop branch.

The differences in number of test reported is already scaring me
since. I saw this before in other folders and is nothing good...

I think you are ok with getting some method to work over since I think
the team working right now on this is not already using the same
rules. For example I saw Alex said to Jose to not run -createImages,
but I think you and I consesuated to use it...we should something
unified and all people working on it should get over that rules.


2012/8/27 Peter Ent <pent@adobe.com>:
> Thanks. So we have two issues.
>
> When I run components/DataGrid, I now consistently get 1293 passes and 0
> failures. You are seeing only 873 passes. I wonder what happened to the
> other 420 tests? Did you sync with [1]?
>
> We are concerned that images creates on system A will not match on system
> B and it looks like that may be the case here. We are trying to get 100%
> of the tests to work and pass for everyone.
>
> Maybe the thing to do is to take a single, but comprehensive, set of
> tests, and figure out how to get 100% of them to work for everyone and in
> doing so, apply what we learn to the rest of the mustella tests.
>
> --peter
>
> [1]
> https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop/mustel
> la/tests/components/DataGrid
>
> On 8/27/12 10:10 AM, "Carlos Rovira" <carlos.rovira@codeoscopic.com> wrote:
>
>>Hi Peter,
>>
>> ./mini_run.sh tests/components/DataGrid/  does not work for me. It
>>reports 21 failures. Then reruning with -createImages flag it passed:
>>
>>[java] =====================================================
>>     [java]     Passes: 873
>>     [java]     Fails: 0
>>     [java] =====================================================
>>
>>I'm on Mac 10.8
>>
>>
>>
>>2012/8/24 Peter Ent <pent@adobe.com>:
>>> I've completed components/DataGrid. I wound up repairing a number of
>>>tests due to changes in (x,y) cursor position and in a couple of cases,
>>>the wrong image asset was being used. If anyone on a Mac could re-test
>>>components/DataGrid after syncing to the development branch, that would
>>>be helpful to see how things compare.
>>>
>>> ./mini_run.sh tests/components/DataGrid/
>>>
>>> Thanks,
>>> Peter
>>
>>
>>
>>--
>>Carlos Rovira
>>Director de Tecnología
>>M: +34 607 22 60 05
>>F:  +34 912 35 57 77
>>CODEOSCOPIC S.A.
>>Avd. del General Perón, 32
>>Planta 10, Puertas P-Q
>>28020 Madrid
>



-- 
Carlos Rovira
Director de Tecnología
M: +34 607 22 60 05
F:  +34 912 35 57 77
CODEOSCOPIC S.A.
Avd. del General Perón, 32
Planta 10, Puertas P-Q
28020 Madrid

Mime
View raw message