incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicholas Kwiatkowski <nicho...@spoon.as>
Subject Re: Switching to AIR 3.4
Date Tue, 28 Aug 2012 14:34:42 GMT
On Mon, Aug 27, 2012 at 7:06 PM, Om <bigosmallm@gmail.com> wrote:

> On Mon, Aug 13, 2012 at 4:58 AM, Nicholas Kwiatkowski <nicholas@spoon.as
> >wrote:
>
> > Om,
> >
> > Which version of AIR did you compile this with?  I've mentioned it
> before,
> > but I keep getting the "This application uses a version of Adobe AIR that
> > is out of date."  This is both on my work PC and Laptop (both are on AIR
> > 3.2).
> >
> > Updating to AIR 3.3 allowed me to install the app.
> >
>
> Nick,
>
> I have tried to repro this with different AIR versions, but no luck.  This
> is built using the shipping version of Apache Flex 4.8 - hence uses AIR 3.1
> for the packaging.
>
>
Yeah, there are some changes that are required for it to work with AIR 3.4.
 I've got a build on my machine at home that 'works' with it, but I'm not
willing to share at the moment because I broke a bunch of other things :)

I was able to correct the issue by blowing away all copies of AIR on my
machine.  It seems there was a beta from way back when that was causing the
issue, even though I have the released 3.4 installed at the time.



>
> >
> > Additionally, there was two points where Windows decided that the app was
> > no longer responding, and asked me if I wanted to close it.  During the
> MD5
> > verification, and after it downloaded the AIR integration kit (and seemed
> > to be extracting it).  It is possible to be doing some green threading
> > during those phases to allow frames to continue to process?
> >
> > -Nick
>
>
> This is because the uncompressing of the zip files and the MD5 hash
> generation are both CPU intensive and hence lock the UI.
>
>
Understood.  Merely wanted to point it out.


> This is good reason to upgrade to AIR 3.4 to make use of the Workers API.
> But that raises a couple of issues:
>
> 1.  Apache Flex 4.8 is targeted to work with AIR 3.1.  What are our plans
> to add AIR 3.4 support?  Can we just upgrade and see what happens?
>
>
Mostly, you need to update some of the version numbers -- and I'm sure
there are some side-effects of using the new swf version too.  I haven't
done a full test suite on it yet, but this may be a job for our CI or
mustella tests.


> 2.  To debug the Workers api, one would need to use the pre-release version
> of Flash Builder 4.7.  Obviously not everyone on Apache Flex has access to
> the pre-release build.  It is bad form for me to switch to 4.7 and check
> this kind of code into Apache Flex SVN?
>
>
Flash Builder 4.7 just got released to labs.
http://labs.adobe.com/technologies/flashbuilder4-7/

I also know the JetBrains and FDT guys are working on this support too.
 I'd imagine they are not too far behind.

-Nick

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message