incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Barragan <jose.barra...@codeoscopic.com>
Subject Re: [jira] [Commented] (FLEX-33177) Getting Mustella mx folder to Work
Date Mon, 27 Aug 2012 23:14:28 GMT
Hi Alex,

I just commit the patch with all changes applied even fix MaskEffect_Properties.mxml as you
commented me.

Regards the Assets path rewrite, when I made then load correctly the resources, if you look
the baseline changes, you may see that issue is older, because the original baselines include
the "unload resource icon". In fact the really error was an extra ../ in the path, I remove
"assets/.." for aesthetic.

mx/effects/Effect/seek works for me, but I suppose that perhaps I'm a little blind in this
problem, because I'm use MacOSX and a lot of these tests are excluded for my platform, perhaps
some of them are those that fail to you.

I attempt to maintain the goal of the tests, and I try to follow the procedure that you have
indicated to Carlos, therefore except for errors, I believe that I am following the correct
methodology.

Thanks,

--Jose

On Aug 27, 2012, at 11:29 PM, Alex Harui <aharui@adobe.com> wrote:

> Hi Jose,
> 
> I've been looking at your proposed changes in more detail.  I saw one thing
> we probably need to explain better:
> 
> In MaskEffect_Properties.mxml you changed the AssertPixelValue value from 0
> to "#FFFFFF".  I suspect the correct thing to do would be to change the
> coordinates of the pixel being tested because the tests seem to have a
> predominately white background and I believe this assert is trying to prove
> that something resized to a position and covered the white background with
> something black.
> 
> This means you have to actually take the time to understand the goal of the
> test and not just change values so the errors go away.  There are some other
> tests with AssertPixelValue modifications that need another look.
> 
> Other changes I saw were changing paths to assets from "../../..." to
> "assets/../../../..." which end up pointing to the same folder, so I don't
> understand why that change is proposed.  Also, the folder is really called
> "Assets" (capital 'A'): it is small 'a' in some of the files, but really, I
> don't think it should be changed there at all.
> 
> Finally, I haven't looked at your proposed baseline changes, but I did
> notice that your patch did not include some baselines in
> mx/effects/Effect/seek that are not matching up for me.  Are the
> mx/effects/Effect tests running without errors?  I'm seeing plenty of errors
> when I run these tests.
> 
> 
> -- 
> Alex Harui
> Flex SDK Team
> Adobe Systems, Inc.
> http://blogs.adobe.com/aharui
> 


Mime
View raw message