incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiel <kiel.s.sinfu...@gmail.com>
Subject Re: Getting Mustella to work.
Date Wed, 29 Aug 2012 09:48:56 GMT
Greetings,

I'm having these results.

First run:
./mini_run.sh tests/Application
=====================================================
     Passes: 233
     Fails: 50
=====================================================

2nd run:
./mini_run.sh -createImages tests/Application
=====================================================
     Passes: 272
     Fails: 15
=====================================================

3rd run:
./mini_run.sh tests/Application
=====================================================
     Passes: 272
     Fails: 15
=====================================================

(Expecting that this should be same as 1st Result)
did a svn revert to undo the -createImages

4th run:
./mini_run.sh tests/Application
=====================================================
     Passes: 237
     Fails: 50
=====================================================

(Expecting that this should be same as 1st Result)
4 Missing Passes: Result 1 vs Result 4
Application_Binding_ExplicitConstraints_Tests_Halo

I'm kinda getting lost in the process...

Regards,

On 8/28/2012 9:11 PM, Carol Frampton wrote:
>
> On 8/28/12 5 :53AM, "Erik de Bruin" <erik@ixsoftware.nl> wrote:
>
>> -createImages is now the default run option?
> Personally I think you should not use -createImages the first time you run
> the tests.  Use imageDiff to make sure the failures are just font
> differences.  If they are then rerun with -createImages.  If you use
> -createImages right away you won't find other problems because they now
> become the "good" images.
>
>> EdB
>>
>>
>>
>> On Tue, Aug 28, 2012 at 11:50 AM, Carlos Rovira
>> <carlos.rovira@codeoscopic.com> wrote:
>>> Hi Erik,
>>>
>>> just try the Applications folder with:
>>>
>>> ./mini_run.sh -createImages tests/Application/
>>>
>>> [java] =====================================================
>>>       [java]     Passes: 273
>>>       [java]     Fails: 0
>>>       [java] =====================================================
>>>
>>> I'm on Mac OSX 10.8.1, as you say there's a missing tess the 124... :?
>>> (maybe in Exclussion list?)
>>>
>>> Maybe Peter could know something about it.
>>>
>>> But, what is clear is that this folder seems ok...
>>>
>>>
>>>
>>> 2012/8/28 Erik de Bruin <erik@ixsoftware.nl>:
>>>> Carlos,
>>>>
>>>>> you should try to rerun with -createImages flag. See if that helps
>>>> I just did: I fetched a clean working copy of the develop branch of
>>>> the SDK and ran "./mini_run.sh tests/Application -createImages"
>>>>
>>>> It now passes 273 tests... which is a bit more than the table on the
>>>> Wiki suggests there should be (124). Weird, or just a whoopsie in the
>>>> table?
>>>>
>>>> Should I run all test with "-createImages"? Or only the first time I
>>>> run a test?
>>>>
>>>> EdB
>>>>
>>>>
>>>>
>>>> --
>>>> Ix Multimedia Software
>>>>
>>>> Jan Luykenstraat 27
>>>> 3521 VB Utrecht
>>>>
>>>> T. 06-51952295
>>>> I. www.ixsoftware.nl
>>>
>>>
>>> --
>>> Carlos Rovira
>>> Director de Tecnología
>>> M: +34 607 22 60 05
>>> F:  +34 912 35 57 77
>>> CODEOSCOPIC S.A.
>>> Avd. del General Perón, 32
>>> Planta 10, Puertas P-Q
>>> 28020 Madrid
>>
>>
>> -- 
>> Ix Multimedia Software
>>
>> Jan Luykenstraat 27
>> 3521 VB Utrecht
>>
>> T. 06-51952295
>> I. www.ixsoftware.nl


Mime
View raw message