incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Moore" <Jason.Mo...@harksolutions.co.uk>
Subject Build Fail... but I'm new at this.
Date Tue, 10 Jul 2012 17:31:32 GMT
Hi All,

 

I've been watching this flex mailing list for a while and as it looks
like nearing a release I thought I'd better have a go at compiling and
checking it against our flex applications here...

 

But I'm hitting a build error... 

 

[Extract]

 

batik:

     [echo] This target should be run with Java 1.4.2_14. It doesn't
work with Java 1.5.

 

batik-jars-check:

 

batik-jars:

 

init-args:

 

init:

 

compile:

     [echo] debug true, optimize on, deprecation off

    [javac]
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\build.xml:412: warning:
'includeantruntime' was not set, defaulting to build.sysclasspath=last;
set to false for repeatable builds

    [javac] Compiling 1428 source files to
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\classes

    [javac]
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\sources\org\apache\flex
\forks\batik\ext\awt\image\codec\tiff\TIFFEncodeParam.java:25: error:
package com.sun.image.codec.jpeg does not exist

    [javac] import com.sun.image.codec.jpeg.JPEGEncodeParam;

    [javac]                                ^

    [javac]
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\sources\org\apache\flex
\forks\batik\ext\awt\image\codec\tiff\TIFFEncodeParam.java:108: error:
cannot find symbol

    [javac]     private JPEGEncodeParam jpegEncodeParam = null;

    [javac]             ^

    [javac]   symbol:   class JPEGEncodeParam

    [javac]   location: class TIFFEncodeParam

    [javac]
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\sources\org\apache\flex
\forks\batik\ext\awt\image\codec\tiff\TIFFEncodeParam.java:304: error:
cannot find symbol

    [javac]     public void setJPEGEncodeParam(JPEGEncodeParam
jpegEncodeParam) {

    [javac]                                    ^

    [javac]   symbol:   class JPEGEncodeParam

    [javac]   location: class TIFFEncodeParam

    [javac]
D:\ApacheFlex\FlexBuild\modules\thirdparty\batik\sources\org\apache\flex
\forks\batik\ext\awt\image\codec\tiff\TIFFEncodeParam.java:316: error:
cannot find symbol

    [javac]     public JPEGEncodeParam getJPEGEncodeParam() {

    [javac]            ^

 

[Extract] it continues with more Image class errors...

 

The ApacheFlex ReadMe build guide suggests JAVA 1.6 ... though
admittedly I'm using the latest Java JDK 1.7.0_05  ... is this the
issue? 

Will rolling back to Java 1.6 fix it.. though  the batik message
suggests with Java 1.4.2_14 ?

 

Apologies if I'm being an idiot.. other people seem to have had better
success.

 

Jason :)  

 

 

________________________________

Hark Solutions Limited. Registered office: Unit 2 Cropmead , Crewkerne,
Somerset, UK, TA18 7HQ. 
Company registration number: 05293155. VAT number: 849 5393 75.
www.harksolutions.co.uk. 
This email and any attachments to it may be confidential and are
intended solely for the use of the individual to whom it is addressed.
Any views or opinions expressed are solely those of the author and do
not necessarily represent those of Hark Solutions Ltd.
If you are not the intended recipient of this email, you must neither
take any action based upon its contents, nor copy or show it to anyone.
Please contact the sender if you believe you have received this email in
error.
Checked by AVG - www.avg.com
Version: 10.0.1424 / Virus Database: 2437/5123 - Release Date: 07/10/12


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message