incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Ent <p...@adobe.com>
Subject Update: Installing Apache Flex 4.8.0
Date Fri, 27 Jul 2012 19:34:56 GMT
Just a quick updateŠ

Here's a list of steps to get the Apache Flex 4.8.0 to work Flash Builder
4.6 on Mac OS X:

1. Download the apache-flex-sdk-4.8.0-incubating-bin.tar from the Apache
distribution site.

2. Unpack the file and rename it (4.8.0). You don't have to do this, but
it makes it easier to work with.

NOTE: Once you have unpacked the distribution, read the file, README, in
the directory as much of what is explained below is also in that file.

3. Move the new 4.8.0 directory to /Applications/Adobe Flash Builder
4.6/sdks, alongside the 3.6.0 and 4.6.0 directories that are already there.

4. Use the Terminal app and cd to the 4.8.0 frameworks directory:
	cd /Applications/Adobe Flash Builder 4.6/sdks/4.8.0/frameworks

5. Run the following command to complete the installation:
	ant thirdparty-downloads

NOTE: You will be asked to confirm the license agreement several times, so
don't walk away. I found that the download of one of the files failed, but
when I tried ant again, it worked without any failures. The process does
not take too long.

6. Inside of the 4.8.0 directory you'll find a file called
env-template.properties. Make a copy of the file and call it
env.properties. Edit this file and set the following values:

	env.AIR_HOME=../../4.6.0
	env.PLAYERGLOBAL_HOME=../../4.6.0/frameworks/libs/player
	env.FLASHPLAYER_DEBUGGER=/Applications/Adobe Flash Builder
4.6/player/mac/11.1/Flash Player Debugger.app/Contents/MacOS/Flash Player
Debugger

Since AIR does not come with Apache Flex, you can use the version that
comes with Flash Builder 4.6.0 or get a new copy from Adobe (see the
README file in the 4.8.0 directory). Likewise, Apache Flex does not come
with the playerglobal.swc, so you can borrow the one that comes with Flash
Builder 4.6. 

You can also download a newer playerglobal.swc if you have upgraded the
Flash Player (debugger version for Flash Builder) from
http://www.adobe.com/support/flashplayer/downloads.html#fp11, making sure
you adjust the paths assigned to env.PLAYERGLOBAL_HOME and
env.FLASHPLAYER_DEBUGGER.

7. With the env.properties file edited and saved, start Flash Builder 4.6
and open its preferences (Flash Builder menu->Preferences). Select "Flash
Builder" and then "Installed Flex SDKs".

8. In the panel that opens, pick "AddŠ" and then BrowseŠ to locate the
/Applications/Adobe Flash Builder 4.6/sdks/4.8.0 directory and pick the
Open button. The "Flex SDK" name field should then read "Apache Flex
4.8.0" which confirms you have selected the correct directory.

At this point you can make this your default SDK and rebuild your
projects. If you get any errors about not being able to locate AIR or the
playerglobal.swc, double-check the paths in the env.properties file. Once
you correct the file, just rebuild (or clean) the projects and the errors
will go away.

I will be doing Windows 7 next.

--peter


On 7/27/12 8:42 AM, "Peter Ent" <pent@adobe.com> wrote:

>Hi,
>
>I'm going to review the process for installing Apache Flex 4.8.0 and
>install it on Mac OS X and Windows 7 - the environments I have readily
>available - so as to be able to help resolve any problems and streamline
>the process. I've noticed a few good tips and articles already, so I'll
>use those as a baseline. I am hopeful that we can put up a simple set of
>instructions onto the Wiki.
>
>Send me any pointers or issues you have discovered so I can include
>those. I'll post any further discovers and/or progress to this email
>thread.
>
>Thanks,
>Peter Ent
>Flex SDK Team
>Adobe Systems


Mime
View raw message