incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: Install 4.8 with flashbuilder
Date Wed, 25 Jul 2012 13:59:58 GMT
Check out this blog post, HOW TO INSTALL APACHE FLEX 4.8.0 SDK IN FLASH
BUILDER

http://lucamezzalira.com/2012/07/24/how-to-install-flex-4-8-0-sdk-in-flash-
builder/


You can hand build you Flex SDK for FlashBuilder, you can use the AIR app,
on OSX you can use ide/flashbuilder/makeApacheFlexForFlashBuilder.sh or,
at your own risk, on Windows if you have scripting enabled and are 32-bit
you can use makeApacheFlexForFlashBuilder.bat (edit line 92 and prepend
"call" so it looks like call ant -f
"%FLEX_HOME%/frameworks/downloads.xml").

Carol

On 7/24/12 5 :39PM, "Kenneth Sutherland" <kenneth@kennethsutherland.com>
wrote:

>Hi I thought I¹d try and quickly install the 4.8 sdk with flashbuilder
>and I¹ve run into a few issues.
>Chances are high I¹m doing something silly in which case at least it
>might highlight that a few more instructions are needed.
>
>Here is what I did -
>  a.. went to http://incubator.apache.org/flex/  and went to the download
>SDK area 
>  b.. Downloaded the binaries for windows
>  c.. extracted and placed them into a folder inside the sdk¹s for
>flashbuilder. 
>  d.. added the sdk to the list of flashbuilder sdk¹s & updated the
>application namespace to be 3.4 inside my AIR app xml file (I thought I¹d
>test out AIR 3.4 at the same time)
>This resulted in errors which seem to relate to paths.
>Initially it came up with something like - unable to open 'C:\Program
>Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.8.0 -
>Copy\frameworks\{airHome}\airglobal.swc'
>
>So I had a look at the readme which stated that I needed to add various
>environment vars etc. So I did (AIR_HOME, PIXELBENDER_HOME,
>PLAYERGLOBAL_HOME, FLASHPLAYER_DEBUGGER & PLAYERGLOBAL_HOME, JAVA_HOME,
>ANT_HOME).
>I didn¹t think this would do as the path issue was inside of Flashbuilder
>(and it didn¹t) so I also updated the env-template.properties.
>
>This then changed the errors to something like this -
>unable to open 'C:\Program Files (x86)\Adobe\Adobe Flash Builder
>4.6\sdks\4.8.0 - 
>Copy\frameworks\C:\AIR_3.1_SDK\frameworks\libs\air\airglobal.swc'
>
>So as you can see its replaced the {airHome} with the correct path, but
>its appended it to the SDK folder.
>
>So what am I doing wrong, do I need get the code and compile it to get a
>SDK?
>The docs say its compatible with SDK 4.6.0 so I thought maybe I should
>merge the 4.8 SDK folder into the 4.6 SDK (in the same way when you
>update a new AIR SDK into an existing Flex SDK folder), but that didn¹t
>work either.
>Maybe my issue is the AIR 3.4 SDK but I don¹t think so, it seems like a
>simple path issue, but I¹m not sure what.
>
>Thanks.


Mime
View raw message