incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: building flex
Date Tue, 03 Jul 2012 06:24:38 GMT



On 7/2/12 7:47 AM, "Alexandre Madurell" <alexandre.madurell.flex@gmail.com>
wrote:

> Thanks Justin,
> 
> Source, actually (at first I tried binary, then source... my current issues
> are with source).
> 
> It's basically target PackageMXP that fails. It's looking for stuff in the
> folder \frameworks\projects\ instead of
> \frameworks\projects\flash-integration\
> 
> I've modified the build.xml and FlexComponentKit.mxi so as to point to the
> correct folders, then it succesfully runs that target.
> 
> The build.xml gave me permission-related problems (it couldn't create
> /frameworks/flash-integration/FlexComponentKit.mxp, so I replaced the code
> to create it
> in /frameworks/projects/flash-integration/FlexComponentKit.mxp).
> 
>     <target name="PackageMXP" if="ADOBE_EXTENSION_MANAGER.set" >
>         <echo message="Creating MXP file
> ${FLEX_HOME}/frameworks/projects/flash-integration/FlexComponentKit.mxp" />
>         <exec executable="${env.ADOBE_EXTENSION_MANAGER}" dir="${basedir}"
> failonerror="true">
>             <arg value="-suppress" />
>             <arg value="-package" />
>             <arg value="mxi=${basedir}/FlexComponentKit.mxi" />
>             <arg
> value="mxp=${FLEX_HOME}/frameworks/projects/flash-integration/FlexComponentKit
> .mxp"
> />
>         </exec>
>     </target>
> 
> Then, all source values in the FlexComponentKit.mxi needed to be preceded
> with flash-integration/
> 
> Once I had that, the main build would run, but it would still get stuck in
> the next step (Compiling frameworks/libs/authoringsupport.swc), with a:
> 
> [compc] Error: Inconsistant linkage in
> D:\adobe\flash\player\11.3\playerglobal.swc(flash.utils:ByteArray,
> flash.utils:CompressionAlgorithm, flash.utils:IDataInput2,
> flash.utils:IDataOutput2) - 'flash.utils:ByteArray' is marked as external,
> but 'flash.utils:IDataInput2' is not.
> 
> Any clues?
> 
I will try to take a look on Tuesday.

-- 
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message