incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Ruiz <daniel.r...@gmail.com>
Subject Re: InstallApacheFlex badge installer - first look
Date Thu, 19 Jul 2012 00:01:47 GMT
Hi,

I just executed on debug mode, I dont think this is actually a problem to
resolve in the installer itself.

TMG Forefront (Microsoft Threat Management Gateway) is active here in the
customer I'm currently working for - and the SDK download zip file is
actually an HTML created by TMG (which has the button 'download' after the
TMG scans the file) - After some timeout occurs if the whole thing is
downloaded or already cached in TMG it just redirects the browser and a
download popup shows up..


I'm sorry to have wrongly reported this. (Error was actually trying to
unzip it not on the 'download' method itself - and the UI was reporting it
correctly)



D.

On Thu, Jul 19, 2012 at 11:05 AM, Om <bigosmallm@gmail.com> wrote:

> On Wed, Jul 18, 2012 at 3:55 PM, Daniel Ruiz <daniel.ruiz@gmail.com>
> wrote:
>
> > Hi,
> >
> > Few things:
> >
> > Direct Connection:
> >
> >  - Badge Installer on MacOS: Failed to install because I had a previous
> > version installed; Removing and installing again worked well;
> >
> >
> It is most probably because you had it signed on a different machine (yours
> vs. mine)  Going forward, building on a single build machine, with an
> increment to the version number each time should work fine.  I tested this
> on my machine, I get an 'update' path instead of a 'install' path in the
> AIR installation process.
>
> The build script needs to be fixed to automatically bump up the version
> number every time the script is run.  Does anyone want to submit a patch
> for this?  The code is available here:
> http://svn.apache.org/repos/asf/incubator/flex/utilities/InstallApacheFlex/
>
> This would be highly appreciated.
>
>
> > Proxy:
> >
> >  - Installer checkout from SVN;
> >  - Updated paths to 4.6 SDK;
> >  - Ant Build, failed to get timestamp resolved adding a -tsa none into
> the
> > packageair task ADT command;
> >  - Run the App, trying to download - failed, it seems it does not find
> the
> > system proxy settings in Windows XP.
> >
> > TEST:
> >  - Started IE / Chrome, URL
> >
> >
> http://people.apache.org/~cframpton/ApacheFlexRC/release_candidate_3/binaries/apache-flex-sdk-4.8.0-incubating-bin.zip
> > -
> > download start just fine.
> >
> >
> > Am I missing something??
> >
> >
> I have seen this problem once before (Windows 7).  Are you using Fiddler?
> I noticed that Fiddler was acting as the proxy and somehow messing up the
> AIR app's ability download.  Can you please investigate further and see if
> there is some issue with the code itself?
>
> Thanks for testing :-)
>
> Om
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message