incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenneth Sutherland" <kenn...@kennethsutherland.com>
Subject Install 4.8 with flashbuilder
Date Tue, 24 Jul 2012 21:39:19 GMT
Hi I thought I’d try and quickly install the 4.8 sdk with flashbuilder and I’ve run into
a few issues.
Chances are high I’m doing something silly in which case at least it might highlight that
a few more instructions are needed.

Here is what I did -
  a.. went to http://incubator.apache.org/flex/  and went to the download SDK area 
  b.. Downloaded the binaries for windows 
  c.. extracted and placed them into a folder inside the sdk’s for flashbuilder. 
  d.. added the sdk to the list of flashbuilder sdk’s & updated the application namespace
to be 3.4 inside my AIR app xml file (I thought I’d test out AIR 3.4 at the same time) 
This resulted in errors which seem to relate to paths.
Initially it came up with something like - unable to open 'C:\Program Files (x86)\Adobe\Adobe
Flash Builder 4.6\sdks\4.8.0 - Copy\frameworks\{airHome}\airglobal.swc'

So I had a look at the readme which stated that I needed to add various environment vars etc.
So I did (AIR_HOME, PIXELBENDER_HOME, PLAYERGLOBAL_HOME, FLASHPLAYER_DEBUGGER & PLAYERGLOBAL_HOME,
JAVA_HOME, ANT_HOME).
I didn’t think this would do as the path issue was inside of Flashbuilder (and it didn’t)
so I also updated the env-template.properties.

This then changed the errors to something like this - 
unable to open 'C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.8.0 - Copy\frameworks\C:\AIR_3.1_SDK\frameworks\libs\air\airglobal.swc'

So as you can see its replaced the {airHome} with the correct path, but its appended it to
the SDK folder.

So what am I doing wrong, do I need get the code and compile it to get a SDK?
The docs say its compatible with SDK 4.6.0 so I thought maybe I should merge the 4.8 SDK folder
into the 4.6 SDK (in the same way when you update a new AIR SDK into an existing Flex SDK
folder), but that didn’t work either.
Maybe my issue is the AIR 3.4 SDK but I don’t think so, it seems like a simple path issue,
but I’m not sure what.

Thanks.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message