incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Fisher <>
Subject Re: Package com.sun.image.* not Found when building Flex Source RC3
Date Sat, 14 Jul 2012 17:18:51 GMT

On Jul 14, 2012, at 8:55 AM, Jeffry Houser wrote:

> On 7/14/2012 11:41 AM, Dave Fisher wrote:
>> Anyway this is an example about why it is best to try to contribute upstream and
use the unaltered project code if possible.
> I have to admit I am not sure if this sentence is directed at me, at Flex, or at Batik.

It is directed at Flex. This project should spend some effort to avoid have special patches
of other projects. At a minimum there should be an effort to take in Batik's efforts to be
1.7 compatible. You may have noticed some warnings related to 1.5 vs. 1.4 with some enums
in either Velocity or Batik.

I am pretty sure that this removed com.sun codec issue is a problem for projects besides Batik.
I think it is also a case within Apache PDFBox, but I have to ask one of my developers about

>> The project should note somewhere on the DL page that there are build issues with
Java 7 and what those are, but it is not a release blocker - IMO.
> I might recommend adding this to the readme file.  I'm still under the belief that my
interpretation that 1.7 meets the "1.5.0_13 or higher" requirement is not an unusual interpretation.

Agreed, and others are discussing this aspect.


> -- 
> Jeffry Houser
> Technical Entrepreneur
> 203-379-0773
> --
> UI Flex Components: Tested! Supported! Ready!
> --
> --
> Part of the DotComIt Brain Trust

View raw message