incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <>
Subject Re: time to help test the release candidate
Date Wed, 27 Jun 2012 21:55:16 GMT which is the
currently, the current kit should have the fix for this problem.  If you
could give it a try I'd appreciate it.


On 6/26/12 11 :56AM, "Dasa Paddock" <> wrote:

>On Jun 26, 2012, at 8:13 AM, Carol Frampton wrote:
>> On 6/22/12 6 :46PM, "Dasa Paddock" <> wrote:
>>> I downloaded the latest from
>>>, ran the
>>> tool and then created a new SDK in
>>> Builder 4.6. I updated my Flex Library Project to use my new 4.8.0 SDK
>>> and my project compiles, but I get four warnings like this:
>>> "The swc '/Applications/Adobe Flash Builder
>>> 4.6/sdks/4.8.0/frameworks/libs/charts.swc' has style defaults and is in
>>> the library-path, which means dependencies will be linked in without
>>> styles.  This can cause applications, which use the output swc, to have
>>> missing skins.  The swc should be put in the external-library-path."
>>> When I look at my project settings under Flex Library Build Path ->
>>> Library path, the Framework linkage is "Use default (external)".
>>> If I then expand the charts.swc under Apache Flex 4.8.0, the Link Type
>>> "Merged into code".
>>> Do I need to manually change it to External like it was for 4.6.0?
>>>When I
>>> double click on that, the options dialog that opens does not have "Same
>>> as framework" checked.
>>> Can this be changed so that it behaves the same as for SDK 4.6.0?
>> I'm not sure what you want changed.
>> I built a FlashBuilder SDK yesterday afternoon with
>> In FlashBuilder v4.6, I added my Apache Flex 4.8.0 SDK.  I created a new
>> Flex project called charts, selected the Apache Flex 4.8.0 SDK, and took
>> all the defaults.  I then cut and pasted the contents of BasicPie.mxml
>> from 
>> -8000.html into the chart.mxml.  It build cleanly.
>> If I look at the project's Properties -> Library Path the Framework
>> linkage is "Use SDK default (merged into code)".  If I click into
>> charts.swc the Link Type is "merged into code".
>> Caro
>It is fine for a regular Flex Project. My issue is when creating a new
>"Flex Library Project". If you try that, the "Framework linkage" is "Use
>default (external)", but all the swcs are set to merge and their Linkage
>"Same as framework" checkbox is not checked. I don't think library
>projects should merge in the Flex SDK swcs and this was working fine with
>SDK 4.6.0.

View raw message