incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pepe <pepe.f...@gmail.com>
Subject Re: time to help test the release candidate
Date Wed, 27 Jun 2012 12:26:43 GMT
Hi, Carol.

add defaults.css into the library project
set -include-file compiler option and point the defaults.css
add a class into library project at least

then, you will get warnings.

thanks

Shigeru Nakagaki


2012/6/27 Carol Frampton <cframpto@adobe.com>:
>
>
> On 6/26/12 11 :56AM, "Dasa Paddock" <dpaddock@esri.com> wrote:
>
>>
>>On Jun 26, 2012, at 8:13 AM, Carol Frampton wrote:
>>
>>>
>>>
>>> On 6/22/12 6 :46PM, "Dasa Paddock" <dpaddock@esri.com> wrote:
>>>
>>>> I downloaded the latest from
>>>> http://people.apache.org/~cframpton/ApacheFlexRC/current/, ran the
>>>> makeApacheFlexForFlashBuilder.sh tool and then created a new SDK in
>>>>Flash
>>>> Builder 4.6. I updated my Flex Library Project to use my new 4.8.0 SDK
>>>> and my project compiles, but I get four warnings like this:
>>>>
>>>> "The swc '/Applications/Adobe Flash Builder
>>>> 4.6/sdks/4.8.0/frameworks/libs/charts.swc' has style defaults and is in
>>>> the library-path, which means dependencies will be linked in without
>>>>the
>>>> styles.  This can cause applications, which use the output swc, to have
>>>> missing skins.  The swc should be put in the external-library-path."
>>>>
>>>> When I look at my project settings under Flex Library Build Path ->
>>>> Library path, the Framework linkage is "Use default (external)".
>>>>
>>>> If I then expand the charts.swc under Apache Flex 4.8.0, the Link Type
>>>>is
>>>> "Merged into code".
>>>>
>>>> Do I need to manually change it to External like it was for 4.6.0?
>>>>When I
>>>> double click on that, the options dialog that opens does not have "Same
>>>> as framework" checked.
>>>>
>>>> Can this be changed so that it behaves the same as for SDK 4.6.0?
>>>
>>> I'm not sure what you want changed.
>>>
>>> I built a FlashBuilder SDK yesterday afternoon with
>>> makeApacheFlexForFlashBuilder.sh
>>>
>>> In FlashBuilder v4.6, I added my Apache Flex 4.8.0 SDK.  I created a new
>>> Flex project called charts, selected the Apache Flex 4.8.0 SDK, and took
>>> all the defaults.  I then cut and pasted the contents of BasicPie.mxml
>>> from
>>>
>>>http://help.adobe.com/en_US/flex/using/WS2db454920e96a9e51e63e3d11c0bf656
>>>8f
>>> -8000.html into the chart.mxml.  It build cleanly.
>>>
>>> If I look at the project's Properties -> Library Path the Framework
>>> linkage is "Use SDK default (merged into code)".  If I click into
>>> charts.swc the Link Type is "merged into code".
>>>
>>> Caro
>>
>>
>>It is fine for a regular Flex Project. My issue is when creating a new
>>"Flex Library Project". If you try that, the "Framework linkage" is "Use
>>default (external)", but all the swcs are set to merge and their Linkage
>>"Same as framework" checkbox is not checked. I don't think library
>>projects should merge in the Flex SDK swcs and this was working fine with
>>SDK 4.6.0.
>
> I see what you are describing in the Flex Library Build Path however I
> don't get the style warning.  I will need to talk to the Flash Builder
> folks and see if they can help diagnose what the issue is.
>
>>
>>Thanks,
>>--Dasa
>

Mime
View raw message