incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Om <bigosma...@gmail.com>
Subject Re: [jira] [Commented] (FLEX-61) AIR version of makeApacheFlexForFlashBuilder for Windows
Date Fri, 08 Jun 2012 18:05:44 GMT
Carol,

This is a bit confusing.  I have a few concerns, hope you dont mind
clarifying it.

1.  Do we really need to worry about adding support for Flash Builder 4.7
in the parity release?  I feel it will be better if we do this in a
subsequent release [1]
2.  Does Flash Builder 4.7 have a release date yet?  If we attempt to add
support for FB 4.7, wont we be tying ourselves with a timeline over which
we have no control?
3.  Are the changes backwards compatible?  That is, can Flash Builder 4.6
and other other IDEs work with these new requirements?
4.  If not, we need to have Flash Builder/other IDE specific installation
steps in the Flex SDK packager.  I thought we were not allowed to use the
name "Flash Builder" in the packager we are building.  How will be let the
user make such a choice then?
5.  Will Apache Flex get early builds of Flash Builder 4.7 so that we can
test that our packager works?  Or do we rely on Adobe/Flash Builder team to
monitor this list and pick up builds and test it internally?
6.  The wording in the README_integration_with_Adobe_FlashBuilder.txt is
misleading:

In the section: *Verifying the validity of the Apache Flex SDK*
The first paragraph says:

--This section applies to the Adobe FlashBuilder v4.6 which has been
> released as well as to Adobe FlashBuilder v4.7 which is currently in
> development at Adobe as of June 2012.--
>

Further down, one of the criteria is:

* The Apache Flex SDK version must be specified in the
> flex-sdk-description.xml file.  The specified version must be 4.8.0 or
> higher.
>

Currently installed versions of Flash Builder 4.6 has no idea about Flex
version 4.8.0.  How will they enforce this critiria?  In fact how will FB
4.6 enforce any such new criteria?

[1] https://cwiki.apache.org/confluence/display/FLEX/Decisions+so+far

Thanks,
Om


On Fri, Jun 8, 2012 at 6:59 AM, Carol Frampton (JIRA) <jira@apache.org>wrote:

>
>    [
> https://issues.apache.org/jira/browse/FLEX-61?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13291784#comment-13291784]
>
> Carol Frampton commented on FLEX-61:
> ------------------------------------
>
> See rev 1348071 for an addition you might want to make for the upcoming
> release of Adobe FlashBuilder.
>
> URL: http://svn.apache.org/viewvc?rev=1348071&view=rev
> Log:
> The upcoming release of Adobe FlashBuilder expects flashbuilder-config.xml
> in the root directory.  This is one of the many checks FlashBuilder makes
> to determine if the given directory is a Flex SDK.  See the added README
> for details.
>
> Added:
>
>  incubator/flex/trunk/ide/flashbuilder/README_integration_with_Adobe_FlashBuilder.txt
>   (with props)
>    incubator/flex/trunk/ide/flashbuilder/flashbuilder-config.xml   (with
> props)
> Modified:
>    incubator/flex/trunk/ide/flashbuilder/build.xml
>    incubator/flex/trunk/ide/flashbuilder/makeApacheFlexForFlashBuilder.bat
>    incubator/flex/trunk/ide/flashbuilder/makeApacheFlexForFlashBuilder.sh
>
>
> > AIR version of makeApacheFlexForFlashBuilder for Windows
> > --------------------------------------------------------
> >
> >                 Key: FLEX-61
> >                 URL: https://issues.apache.org/jira/browse/FLEX-61
> >             Project: Apache Flex
> >          Issue Type: Improvement
> >            Reporter: OmPrakash Muppirala
> >            Assignee: Bertrand Delacretaz
> >         Attachments: bg_logo.png, makebuilder_ui_assets_cs4.fla, rat.log
> >
> >
> > The powershell and vbscript versions of the script has dependence
> issues.  An Adobe AIR version with a captive runtime should not have such
> problems.
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators:
> https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message