incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dasa Paddock <dpadd...@esri.com>
Subject Re: time to help test the release candidate
Date Fri, 22 Jun 2012 22:46:51 GMT
I downloaded the latest from http://people.apache.org/~cframpton/ApacheFlexRC/current/, ran
the makeApacheFlexForFlashBuilder.sh tool and then created a new SDK in Flash Builder 4.6.
I updated my Flex Library Project to use my new 4.8.0 SDK and my project compiles, but I get
four warnings like this:

"The swc '/Applications/Adobe Flash Builder 4.6/sdks/4.8.0/frameworks/libs/charts.swc' has
style defaults and is in the library-path, which means dependencies will be linked in without
the styles.  This can cause applications, which use the output swc, to have missing skins.
 The swc should be put in the external-library-path."

When I look at my project settings under Flex Library Build Path -> Library path, the Framework
linkage is "Use default (external)".

If I then expand the charts.swc under Apache Flex 4.8.0, the Link Type is "Merged into code".

Do I need to manually change it to External like it was for 4.6.0? When I double click on
that, the options dialog that opens does not have "Same as framework" checked.

Can this be changed so that it behaves the same as for SDK 4.6.0?

Thanks,
--Dasa


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message