incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christofer Dutz (JIRA)" <>
Subject [jira] [Commented] (FLEX-48) Building the SDK with Java 7
Date Tue, 05 Jun 2012 12:29:22 GMT


Christofer Dutz commented on FLEX-48:

I was just working on Flexmojos to support JDK 1.7 and stumbled over a problem with the Air
ApplicationPackager ... I know that this is not really related to "building" the SDK with
1.7 but in "using" it with 1.7, but I thought my report should fit here:

As soon as I am using the ApplicationPackager with JDK 1.7 I am getting the following exception:

Caused by: com.adobe.pki.TimestampException: Could not generate timestamp: handshake alert:
	at com.adobe.ucf.UCFSigner.getTimeStampFromURL(
	at com.adobe.ucf.UCFSigner.computeSignatureTimestamp(
	at com.adobe.ucf.UCFSigner.createTimestampXML(
	at com.adobe.ucf.UCFSigner.getSignatureXML(
	at com.adobe.ucf.UCFOutputStream.finalizeSig(
	at com.adobe.air.AIROutputStream.finalizeSig(
	at com.adobe.air.ApplicationPackager.createPackage(
	at net.flexmojos.oss.plugin.air.packager.FlexmojosAIRPackager.createPackage(
	at net.flexmojos.oss.plugin.air.SignAirMojo.doPackage(
	... 26 more

I guess it would be good to add UCFSigner to the list of potentially non-1.7-compilant components.
> Building the SDK with Java 7
> ----------------------------
>                 Key: FLEX-48
>                 URL:
>             Project: Apache Flex
>          Issue Type: Improvement
>            Reporter: Christophe Herreman
>            Assignee: Bertrand Delacretaz
>         Attachments: ImageCacher.patch, SpriteTranscoder.patch, downloads.patch, java-7.patch,
modules-build.xml.patch, modules-compiler-build.xml.patch, modules-thirdparty-batik-build.xml.patch
> I've changed the SDK a bit to be able to build it with Java 7. Everything seems to compile,
although that is no guarantee that things will actually work.
> The main problem is the Batik dependency. The version used by the trunk version is 1.6.
When building with Java 7, this results in some compiler errors for classes in the com.sun.*
packages. So I've updated the build scripts to use Batik version 1.7 (there is an option to
NOT use the Sun classes in the build file of that version) and resolved some more compilation
issues (missing dependency xml-apis-ext.jar, API changes in the dependencies).
> Attached is a patch with the changes. Please try this out if you have a moment and let
me know if this works for you. These changes are compatible with Java 6, so when applying
the patch you should still be able to build the SDK without changing your Java installation.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message