incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <>
Subject Re: Preliminary release candidate of Apache Flex 4.8.0 (for developers only)
Date Fri, 18 May 2012 00:12:46 GMT

On 5/17/12 7 :26PM, "Justin Mclean" <> wrote:

>> In the Apache world, AIR and playerglobal should not be within the Flex
>> structure and we've moved them out.
>Each Flex SDK may need a different playerglobal.swc depending on what
>Flash version it targets. You can work out which Flash Player version an
>SDK was compiled for by looking at flex-config.xml.
>You may need multiple playerglobal.swc if you have multiple SDKs
>installed (which would be fairly common IMO).


I am just getting back to this.  Do you think the build files need to have
something like

    <include name="playerglobal.swc"/>

rather than

<external-library-path dir="${env.PLAYERGLOBAL_HOME}">
    <include name="playerglobal.swc"/>

and the *-config.xml files need


rather than 


The compiler subs {targetPlayerMajorVersion}.{targetPlayerMinorVersion}
with the relavent pices of the <target-player> tag or command line option.
 The default, which btw, I was surprised to see is hard-coded into the
compiler is 11.1.  

As it stands now it is a regression from 4.6 since -target-player does not
do what it should be doing in the frameworks/*-config files.


View raw message