incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Avinash Narayanan <avinasha...@gmail.com>
Subject Re: passing url as argument from one air application to another at startup of second air application
Date Tue, 08 May 2012 19:53:55 GMT
Aaah...Thanks for that clarification...I thought I had to search all over
again :) but I really wish Adobe would let us do this or donates air.swf
for the browserInvocation stuff. Its such a pain!

Thanks
Avinash Y

On Wed, May 9, 2012 at 1:12 AM, Omar Gonzalez <omarg.developer@gmail.com>wrote:

> On Tue, May 8, 2012 at 12:32 PM, Avinash Narayanan <avinashapr9@gmail.com
> >wrote:
>
> > Hi Tink & Omar,
> >
> > Thanks for that info. I had tried the escape(), encodeURI(),
> > encodeURIComponent()
> > but they add % which is also not allowed. The only spl. characters
> allowed
> > are :=- and " of course. However the Base64 encoder seems to be working
> > fine (no idea why since byte array wasn't?) but why remove the last '='
> and
> > add it later on? didn't get that logic actually.
> >
> > Thanks
> > Avinash Y
>
>
> I think Tink was suggesting removing the '=' character because you had said
> special characters were the issue. Glad it allows that character though
> since it makes it compatible.
>
> I wouldn't try removing that = sign and replacing it anyhow. Base64
> encoding uses the '=' character to denote the amount of bits left over when
> it encodes to Base64. In some cases it could be 1 equals sign, in some
> cases it can be 2.
>
> Glad you got it working though.
>
> -omar
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message