incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raju Bitter <r.bitter.mailingli...@googlemail.com>
Subject Apache Flex 4.8, playerglobal.swc versions, FP 11.x adoption, FP versions & security
Date Wed, 23 May 2012 20:07:55 GMT
I have a few questions regarding the target player for the 4.8 SDK,
the -swf-version option, playerglobal.swc version, etc. I'd be
thankful for any input.

1) Apache Flex 4.8 and target-player option
I've read in the Adobe Flex 4.6 docs, that the minimum value for the
-target-player option is 11.1 with that version of the SDK:
http://help.adobe.com/en_US/flex/using/WS2db454920e96a9e51e63e3d11c0bf69084-7ee0.html

Wouldn't it be technically possible to compile a pure AS3 application
for a target player with a lower version number? I assume that the 4.8
release will require Flash Player 11.1 as well, is that right?

2) -swf-version option
I guess that option refers to the SWF file format documented here:
http://www.adobe.com/devnet/swf.html

I remember that Alex Harui said that the SWF file format version has
not changed with recent updates of the SDK. Is there a use case where
a value different than "10" should be used for this option?

3) playerglobal.swc
Which versions of the playerglobal.swc can be used with Apache Flex 4.8?

4) FP 11.1, 11.2, 11.3 adoption
Does anyone have any up-to-date numbers on the Flash Player adoption
rate for these versions of FP? Which versions of Flash Player do you
currently target in your applications, especially for consumer apps?

5) Flash Player versions and security
Is it technically less secure to load and run an SWF in FP which
targets the FP 10.x, compared to SWFs compiled for FP 11.x - or the
latest version of FP. I'd say that it doesn't make a difference, since
bugs and security holes are fixed within FP, but maybe that's not
correct.

Thanks,
Raju

Mime
View raw message