incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "christofer.dutz@c-ware.de" <christofer.d...@c-ware.de>
Subject Generating Mavenized versions of older Flex SDKs
Date Fri, 18 May 2012 10:55:49 GMT
I changed the topic as this no longer seemed to be in the context of the thread it was in:

My current list is this:
- Flex SDK version: 2.0.1.180927
- Flex SDK version: 3.0.0.477A
- Flex SDK version: 3.0.1.1732A
- Flex SDK version: 3.1.0.2710A
- Flex SDK version: 3.2.0.3958A
- Flex SDK version: 3.3.0.4852A
- Flex SDK version: 3.4.0.9271A
- Flex SDK version: 3.4.1.10084A
- Flex SDK version: 3.5.0.12683B
- Flex SDK version: 3.6.0.16995A
- Flex SDK version: 4.0.0.14159A
- Flex SDK version: 4.1.0.16076A
- Flex SDK version: 4.5.0.20967A
- Flex SDK version: 4.5.1.21328A
- Flex SDK version: 4.6.0.23201B

At the moment the build of Flexmojos and all of my Flex Projects worked with my version of
4.5.1.21328A
4.6.0.23201B seems to be a little more tricky. Currently I am getting errors that the resource-bundles
can't be found. Haven't tested the other ones. I think I will provide the tool to migrate
to the public in order for people to test the SDKs first. As soon as I get reports that the
new SDKs are stable an work in all needed versions I think I will try to deploy them publically.

But I have to admit, that in the final version I will probably be generating SDK versions
that will be incompatible with older Flexmojos versions (Prior to 5.1)
The reason for that is, that currently all swc,swf, swz files are generated with the version
of the SDK. This is correct for most SDK elements, unfortunately textLayout and osmf never
followed this rule. This made it impossilbe to load the rsl stuff from adobe (There simply
is no osmf lib in version 4.5.1.2132A). The SDKs I will be generating will reference the resources
in their correct version. Unfortunatley older Flexmojos versions rely on the "framework" artifact
having the same version as the SDK it is in ... this was broken by Adobes patched "A" and
"B" SDKs :-( ... I will fix Flexmojos to support this, but the older versions will probably
fail.

Chris




-----Urspr√ľngliche Nachricht-----
Von: Roland Zwaga [mailto:roland@stackandheap.com] 
Gesendet: Freitag, 18. Mai 2012 11:26
An: flex-dev@incubator.apache.org
Betreff: Re: AW: Preliminary release candidate of Apache Flex 4.8.0 (for developers only)

>
> As I am currently working on re-deploying all oft he older Releases 
> back down to Flex 2.0.1 it would be best, If I made those deployments 
> support the new structure.
>

OT:
Does this mean that the 4.6.1 SDK will be deployed as well?

Mime
View raw message