incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tink <f...@tink.ws >
Subject Re: minor Validator improvment
Date Thu, 29 Mar 2012 13:33:47 GMT
On 29 Mar 2012, at 14:23, Jeff Tapper wrote:

>
> This is a good example where method overloading would come in handy.  
> But
> since we don't have that what about just adding  
> Validator.validateAll2();
> which would return a Vector.<ValidationResultEvent>? I don't think  
> we should
> change the input from Array to Vector type though, unless there's a  
> way to
> declare a Vector in MXML. Declaring an Array in MXML and setting up
> validators in MXML that use bindings is convenient and I would use  
> that with
> Validator.validateAll2(); in my form validations.
>
>
>
> I'm fine with the idea of a new method, but we need a more  
> descriptive name
> than valiateAll2.  Any thoughts on a better name?
>


There seems little point in this?

It's difficult to use Vectors in MXML as you say, and therefore this  
is likley to be used only with AS, and therefore you could just do

const results:Vector.<ValidationResultEvent> =  
Vector.<ValidationResultEvent>( myValidator.validateAll() );


Tink

Mime
View raw message