incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Francis Buhler <davidbuh...@gmail.com>
Subject Re: minor Validator improvment
Date Fri, 30 Mar 2012 23:48:23 GMT
The ambiguity regarding what 'all' refers to is confusing (IMO).

On Fri, Mar 30, 2012 at 7:02 PM, Nicholas Kwiatkowski <nicholas@spoon.as> wrote:
> I personally would love to see validateAllAsVector() -- while starting
> the deprecation process of validateAll().  It makes it very clear that the
> purpose of the function is exactly the same, yet the signature is
> different.
>
> -Nick
>
> On Thu, Mar 29, 2012 at 12:05 PM, Omar Gonzalez
> <omarg.developer@gmail.com>wrote:
>
>> On Thu, Mar 29, 2012 at 8:54 AM, David Francis Buhler <
>> davidbuhler@gmail.com
>> > wrote:
>>
>> > Maybe " Validator.getValidationResults".
>> >
>> > When I think of "Validation", I always think of validateNow(),
>> > invalidateDisplayList(,), invalidateProperties, etc. I always think of
>> the
>> > term as a grouping of the invalidation routines.
>> >
>> > I'm just throwing the idea out there (because it has always bothered me!)
>> >
>> >
>> The naming never bothered me cuz it read like a sentence when you take the
>> argument name into consideration, "validate all validators", but I wouldn't
>> be opposed to
>>
>> Validator.getValidationResults(validators:Array):Vector.<ValidationResultEvent>
>>
>> The validateAll2() was just to get the point across, I couldn't think of a
>> better name. But 'getValidationResults()' sounds fine.
>>
>> @Tink: I wasn't aware that you can do Vector.<Blah>(someArray) to cast it
>> to vector, that's handy. But having a convenience method would also be
>> nice, I'm all about convenience, think of the newbies man! :P
>>
>> -omar
>>

Mime
View raw message