incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conrad Winchester <con...@chiwestern.com>
Subject Re: Maven and Flex 4.6
Date Sat, 10 Mar 2012 09:07:31 GMT
Here's how to create a mavenised flex sdk

https://github.com/piercer/flex_sdk_maven_install



On 9 Mar 2012, at 18:04, James Cowan wrote:

> 
> You will see in the reply on the Adobe forum that Adobe have no plans for maven and see
it as Apache's beef.
> 
> Introducing native maven support (or ant *with* ivy) into Flex would be great but things
have been limbo for ages and there are lots
> of improvements between 4.5 (current flexmojos target) and 4.6, not least in the mobile
stuff.
> 
> The practical steps of getting 4.6 working with flexmojos are almost there; someone has
been through the pain of getting the SDK
> uploaded into a Sonatype repo and flexmojos can be recompiled to support it.
> 
> Can Apache Flex not invite Marvin Froeder (the Flex mojos author) to join Apache?
> 
> Is flexmojos license the issue? Can JP Morgan lob some funding over to Marvin Froeder
:-)
> 
> James
> 
> On 09/03/2012 17:56, Skogen, Espen wrote:
>> 4.6 is the adobe release, so that's sort of Adobe's beef. We are looking at introducing
native Maven support for Apache Flex in a future release, but there's no timeline at this
stage.
>> 
>> E:)
>> 
>> 
>> Espen Skogen | Vice President | IB Tech Market | Investment Bank | J.P. Morgan |
125 London Wall, EC2Y 5AJ,  London, United Kingdom | T: +442077420836 | espen.skogen@jpmorgan.com
| jpmorgan.com
>> 
>> -----Original Message-----
>> From: James Cowan [mailto:jamesmcowan@googlemail.com]
>> Sent: 09 March 2012 16:09
>> To: flex-dev@incubator.apache.org
>> Subject: Maven and Flex 4.6
>> 
>> 
>> Hi
>> 
>> what is the situation with maven and flex 4.6?
>> 
>> I posted this message on the Adobe forum and got directed here:
>> 
>> http://forums.adobe.com/message/4246042#4246042
>> 
>> As far as I can tell, Flex SDK 4.6 is now installed in the Sonatype repo
>> here:
>> 
>> https://repository.sonatype.org/content/groups/flexgroup/com/adobe/flex/framework/playerglobal/4.6.b.23201/
>> 
>> The flexmojos plugin is wired to use SDK 4.5.1.21328, but it does work with 4.6.0.23201B
if you change a few of the poms and recompile.
>> 
>> James
>> 
>> This email is confidential and subject to important disclaimers and
>> conditions including on offers for the purchase or sale of
>> securities, accuracy and completeness of information, viruses,
>> confidentiality, legal privilege, and legal entity disclaimers,
>> available at http://www.jpmorgan.com/pages/disclosures/email.
>> 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message