incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Tapper" <j...@spoon.as>
Subject RE: minor Validator improvment
Date Thu, 29 Mar 2012 14:55:00 GMT
Perhaps something like
Validator.validateValidatorArray(array:Array):Vector.<ValidationResultEvent>

-----Original Message-----
From: David Francis Buhler [mailto:davidbuhler@gmail.com] 
Sent: Thursday, March 29, 2012 10:35 AM
To: flex-dev@incubator.apache.org
Subject: Re: minor Validator improvment

I would love it if we could deprecate "validateAll()" and replace it with a
an operation name that suggests the method returns a list.

On Wed, Mar 28, 2012 at 9:35 AM, Jeff Tapper <jeff@spoon.as> wrote:
> There's a couple  of very minor issues I see:
>
> 1.      Method now take an array and returns a vector seems a little 
> inconsistent
>
>
>
> I was debating changing the argument to a vector as well, but haven't 
> yet for two reasons:
>
> a)      several developers I know will wrap their validator mxml in an 
> fx:Array tag, and im not sure you can do that with vectors (how would 
> you specify the datatype?)
>
> b)      As the arguments are an Array of IValidators and the return is 
> an Array of ValidationResultEvents, the input and output aren't really 
> consistent.
>
>
>
> 2.      Anything using validateAll is likely to require changes. Most 
> cases just a type change but vector is missing SortOn method which 
> array has and that might be used.
>
>
>
> True enough, and if enough people feel strongly about this, we can 
> just add a new method instead of replacing the existing one (not sure 
> what to call it though).  Personally, when using the validateAll 
> method, I usually check the length of the return, but don't use many other
Array properties or methods.
>
>
>
>
>
> Justin
>


Mime
View raw message