incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Tapper" <j...@spoon.as>
Subject RE: minor Validator improvment
Date Thu, 29 Mar 2012 13:23:36 GMT

This is a good example where method overloading would come in handy. But
since we don't have that what about just adding Validator.validateAll2();
which would return a Vector.<ValidationResultEvent>? I don't think we should
change the input from Array to Vector type though, unless there's a way to
declare a Vector in MXML. Declaring an Array in MXML and setting up
validators in MXML that use bindings is convenient and I would use that with
Validator.validateAll2(); in my form validations.



I'm fine with the idea of a new method, but we need a more descriptive name
than valiateAll2.  Any thoughts on a better name?


Mime
View raw message