incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject asdoc comments for flash player and SDK version numbers
Date Thu, 16 Feb 2012 07:05:09 GMT
Hi,

Was looking though some of the framework code and noticed that a lot of method are marked
up with comments that are imported into documents re player version and the like.

 Here's a typical section.
     *  @langversion 3.0
     *  @playerversion Flash 9
     *  @playerversion AIR 1.1
     *  @productversion Flex 3

Going forward when adding new methods what are the values we should use? Do we just go with
current versions like so:
     *  @langversion 3.0
     *  @playerversion Flash 11.1
     *  @playerversion AIR 3.1
     *  @productversion Apache Flex 4.7

That's assume that anything submitted will be in the next release when it may not be. Perhaps
just "@productversion Apache Flex" for now with no version number?

Do we try and match previous FP versions? ie if it runs in FP 10.2 use "@playerversion Flash
10.2".

Or do we don't bother adding this information at all and revisit at a later date? Anyone have
a strong view on this?

Thanks,
Justin


Mime
View raw message