incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael A. Labriola" <labri...@digitalprimates.net>
Subject RE: [jira] [Created] (FLEX-14) Flex SDK 4.6 dosn't work on FlashPlayer 10.3 and requires FlashPlayer 11.1
Date Mon, 13 Feb 2012 01:55:43 GMT
>I have no issue with that at all. Could you find any other way  around the issue eg by
just checking FP version numbers in the code or dare I say it monkey patching the missing
classes?

The problem, if I am recalling correctly, is that more than once class has a concrete dependency
on a newer FP version class. So, unfortunately, checking an FP version won't work as we need
to resolve at compile time. I will double check myself on this though.

>Running on 11.1 is probably going to be faster etc but not everyone has that option right
now. IMO lowering the FP version lowers barriers to entry for use of the Apache/Flex SDK and
makes for easier upgrade path.
I agree. I would like to see less forcing of the upgrade path in the future. I wonder if there
is a solution to this problem like, let's say separating logic and injecting dependencies
:) sorry couldn't help it.

>You got this documented anywhere or can you give me a few pointers and I'll give it a
go myself.
When I get to the office in the morning, I will see if we have a doc on the changes. We likely
do. Else I can give you an entire SDK that works and you could just do a quick diff.

Mike
Notice: This transmission is intended only for the use of the individual or entity to which
it is addressed and may contain information that is privileged or confidential. Any dissemination,
distribution or copying of this transmission by anyone other than the intended recipient is
strictly prohibited. If you have received this transmission in error, please notify the sender
immediately by e-mail or telephone and delete the original transmission. Thank you.

Mime
View raw message