incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject Re: [jira] [Commented] (FLEX-15) Change build script to download specified version of playerglobal.swc
Date Wed, 15 Feb 2012 15:44:23 GMT
Hi,

Thanks for that.

It turns out that:
<load-config filename="${basedir}/flex-config.xml" />
<load-config filename="${basedir}/flex-config-${playerglobal.version}.xml" append="true"
/>

Will do the job and compiles the SDK with the wanted version of the Flash Player and swf version.
Issue solved - well almost.

It turns out that Flash Builder reads in flex-config.xml (perhaps obvious in retrospect but
I was unaware it did so) and in particular wants the the flash player version number (to display
as the minimum flash player version in the Flex compiler properties). If you don't have these
values in flex-config.xml FB throws a null pointer exception and can't display that preference
panel. I'd call that a bug but not much can be done about it. Putting in dummy values (ie
lowest possible value of 10.2) works but is misleading as the UI shows the wrong Flash Player
version.

So looks like this is not going to work. Next option I think is to create a template file
copy it and inject the correct values via <replacetokens />.

Thanks,
Justin


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message