incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject Re: [jira] [Created] (FLEX-14) Flex SDK 4.6 dosn't work on FlashPlayer 10.3 and requires FlashPlayer 11.1
Date Mon, 13 Feb 2012 01:33:22 GMT
Hi Mike,

> If we are willing to conditionally compile a few minor places, I can get 4.6 running
on 10.2.
I have no issue with that at all. Could you find any other way  around the issue eg by just
checking FP version numbers in the code or dare I say it monkey patching the missing classes?

> You are correct that there are some loses in doing this but I have it running on 10.2
in the field presently for enterprises who were unwilling to update.
Running on 11.1 is probably going to be faster etc but not everyone has that option right
now. IMO lowering the FP version lowers barriers to entry for use of the Apache/Flex SDK and
makes for easier upgrade path.

You got this documented anywhere or can you give me a few pointers and I'll give it a go myself.

Thanks,
Justin 
Mime
View raw message