incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Monteiro <char...@nycsmalltalk.org>
Subject Can Adobe kill Apache Flex
Date Tue, 21 Feb 2012 19:40:06 GMT
hi, first of all I'm very new here. My timing is off since it seems that
Flex is my best alternative to replace my UI building technology, still is
albeit recent events are confusing things.

So this is what I mean by the subject line. My understanding is that the
Flash and Air runtimes have not been open sourced which poses a
vulnerability , so I think , that whatever advancements made to the
runtimes by Adobe will be incompatible with the Apache Flex project's
advancements. I know there's a lot of talk of using the Falcon compiler to
compile to JS but I really only desire to run on Air or Flash  player.

Am I correct ? Adobe is claiming a buffer period of 5 years for projects
builit with Flash Builder 4 i.e. Flex SDK 4.6x but after 5 years that code
is also subject to be rendered incompatible with the newer runtimes.
There's also the possibility that changes to the Adobe runtimes
to accommodate for example Windows 8 may render Flex apps dead on Windows 8.

All risks I understand but I guess my over reaching question is what is
Apache Flex doing so that Flex will be able to run on the probably forever
to be ubiquitous upcoming Adobe runtimes.

thanks

-- 
Charles A. Monteiro

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message