incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Haykel BEN JEMIA <hayke...@gmail.com>
Subject Re: [jira] [Created] (FLEX-14) Flex SDK 4.6 dosn't work on FlashPlayer 10.3 and requires FlashPlayer 11.1
Date Mon, 13 Feb 2012 07:19:33 GMT
In many cases the requirement for a newer FP version by the SDK is related
to only a very small number of features. I don't know if it is feasible,
but it would be nice to be able to choose the targeted FP version based on
what features are used in the application.

Haykel




On 13 February 2012 03:19, Justin Mclean <justin@classsoftware.com> wrote:

> Hi,
>
> > I foresee many arguments later about specific features that will require
> FP upgrades.
> Well I think we should take the "progressive enhancement" view. if you've
> got the latest then that great it will run a bit faster and may have a
> couple of nice new new features. Enabling developers to target a wider
> range of versions of the Flash Player provide a lot of benefits. Forcing
> the SDK 4.6 to use the very latest released flash player (11.1) was not a
> good move in my view. For one project it stopped us from being able to move
> to the 4.6 SDK and that's likely not to change for some time. I assume the
> FP 11.1 move was done for mobile components/mobile performance?
>
> > With the DI discussions that have been discussed on other threads we
> could
> > create specific managers based on of versions.
> Sounds good to me.
>
> Justin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message