incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andras Csizmadia" <and...@vpmedia.eu>
Subject Re: [jira] [Commented] (FLEX-15) Change build script to download specified version of playerglobal.swc
Date Tue, 14 Feb 2012 22:39:29 GMT
11.1 SDK uses 11.0 playerglobal.swc -> I can confirm this.

And I think the player global 10.2 SWC is not available as a direct download 
only 10.3, you have to download older version of Flex SDK.

fyi: Flash Player archive is here, but the packages are not containing SWC 
files (they should be..)
http://kb2.adobe.com/cps/142/tn_14266.html


Best,
Andrew


-----Original Message----- 
From: Justin Mclean
Sent: Tuesday, February 14, 2012 11:23 PM
To: flex-dev@incubator.apache.org
Subject: Re: [jira] [Commented] (FLEX-15) Change build script to download 
specified version of playerglobal.swc

Hi,

After a little further research it seems that the 11.1 SDK uses the 11.0 
playerglobal.swc and there isn't a 11.1 playerglobal.swc. Can anyone confirm 
this?

Does anyone know if there is an official URL for the 10.2 playerglobal.swc?

Thanks,
Justin

On 14/02/2012, at 7:31 PM, Justin Mclean wrote:

> Hi,
>
> Flex-confg.xml has hard coded the Flash version number and the swf version 
> number. This file is included by build_framework.xml.
>
> The hard coded Flash version number can be easily fixed by changing this 
> (around line 22):
> <target-player>11.1</target-player>
> to
> <target-player>{targetPlayerMajorVersion}.{targetPlayerMinorVersion}</target-player>
>
> The hard coded swf version is a little harder to fix. The only way I see 
> around it is to have a flex-config.xml for each version eg a 
> flex-configXX.Y.xml were XX.Y is one of 10.2,10.3,11.0,11.1 and 11.2  and 
> change the build_framework.xml to include the correct version like so 
> (around line 323):
> <load-config 
> filename="${basedir}/flex-config${playerglobal.version}.xml"/>
> instead of
> <load-config filename="${basedir}/flex-config.xml"/>
>
> If the extra dot in the file name offends anyone it can be changed to a 
> "-" or a "_".
>
> Does anyone have any other ideas? It does seem to duplicate a lot of 
> information
>
> I'm fairly certain teh swf version which correspond to the Flash Player 
> version are:
> Flash Player 10.2 = swf version 11
> Flash Player 10.3 = swf version 12
> Flash Player 11.0 = swf version 13
> Flash Player 11.1 = swf version 14
> Flash Player 11.2 = swf version 15
>
> Anyone know anything different re swf version number vs flash player 
> numbers?
>
> Thanks,
> Justin 


Mime
View raw message