incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Mclean (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-14) Flex SDK 4.6 dosn't work on FlashPlayer 10.3 and requires FlashPlayer 11.1
Date Thu, 16 Feb 2012 23:22:58 GMT

    [ https://issues.apache.org/jira/browse/FLEX-14?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13209882#comment-13209882
] 

Justin Mclean commented on FLEX-14:
-----------------------------------

At a first pass looks like there's there's no SDK code changes required to use the Flex 4.6
SDK in FP 11.0 or 10.3. The SDK compiles without errors for FP11.0 and FP 10.3.

I took an existing large application that uses a mix of mx and spark UI components (using
SDK 4.5) and recompiled it to use Apache Flex SDK 4.6 for Flash Player 10.3 (from the white
board area). There was a minor issue with the version of the flex unit libraries. The version
of the compiled swf was checked with swfdump.

All unit tests passed and the application runs correctly in Flash Player 10.3. There may be
(or not be) an issue with using new FP 4.6 features or some components the the application
doesn't use. Even without further work I think this provides a easier upgrade path to Adobe
Flex 4.6 SDK (and the next build of Apache Flex) for applications currently using older versions
of the Flash Player (11.0,10.3).
                
> Flex SDK 4.6 dosn't work on FlashPlayer 10.3 and requires FlashPlayer 11.1
> --------------------------------------------------------------------------
>
>                 Key: FLEX-14
>                 URL: https://issues.apache.org/jira/browse/FLEX-14
>             Project: Apache Flex
>          Issue Type: Improvement
>            Reporter: Justin Mclean
>            Assignee: Michael Labriola
>            Priority: Minor
>
> Flex SDK 4.6 require a minimum FlashPlayer version of 11.1.
> From a quick look this is related to the new spark validator classes (spark.validators.*)
using FlashPlayer 11 globalisation classes (flash.globalization.*).
> In particular enterprises can be slow to update Flash Player versions and this would
enable a smoother upgrade path to people currently on 4.5 SDK (in a Flash player 10.3 environment)
to the new Apache Flex 4.x SDK.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message