incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Winscot <rick.wins...@gmail.com>
Subject Re: playerglobal.swc version build issue
Date Mon, 23 Jan 2012 20:22:19 GMT
No confusion on my part Alex - I'm well versed in the Flash Player 'branched execution model'
and SWF forward / backward compatibility.

Here's the red-flag for you... what if Adobe decides to expand UIA restrictions to block potentially
unsafe operations? Do you remember this?

"When an ActionScript API function has a UIA requirement, that function can be called only
in response to a user action such as a mouse click or key press. Some previously available
ActionScript 2.0 and ActionScript 3.0 APIs have had UIA restrictions added in Flash Player
10. In addition, some new features and APIs that are newly introduced in Flash Player 10 also
are restricted."

http://www.adobe.com/devnet/flashplayer/articles/fplayer10_uia_requirements.html

As soon as these restrictions were rolled-out, features and functionality in _any_swf_of_any_version
were impacted! Developers who lost step with Flash Player releases and security updates were
in dire-straits. Now, imagine what the landscape will be like with Flash Player updating silently
in the background. Flex is no longer under Adobe's protective wing... when there are problems
( a classic 'when' not 'if' statement ) I'm betting that issues will be discovered later rather
than sooner.

It's irresponsible to think that freezing on a particular version of playerglobal.swc and
setting compatibility version to stun... is a set-it-and-forget-it kind of thing.

Will old SWFs continue to run in new versions of the Flash Player? IMO ( feel free to disagree
), the answer would be 'maybe.' There are many factors that could impact interoperability...
which is ground that is best covered when you come to it. Enterprise customers are going to
want to know that there are watchful eyes looking for these kinds of bumps in the road.

Does this help qualify my statement? 

-- 
Rick Winscot


On Monday, January 23, 2012 at 12:13 PM, Alex Harui wrote:

> 
> 
> 
> On 1/23/12 8:42 AM, "Rick Winscot" <rick.winscot@gmail.com (mailto:rick.winscot@gmail.com)>
wrote:
> 
> > So... moving forward... the near-term success and stability of Apache Flex
> > will be dependent upon how well we keep step with Flash Player releases.
> > 
> 
> Adobe is only promising to support Flex on a particular SWF version number.
> I think it is 13.
> 
> The player has 3 versions, the public name (Flash Player 11 or Flash Player
> 11.1), which consumes a particular SWF File Format version (the latest is
> 10), and runs APIs based on the SWF version. So, Flash Player 11 runs SWF
> Version 13 or lower and supports SWF File Format 10. If we move beyond
> that, we are on our own.
> 
> -- 
> Alex Harui
> Flex SDK Team
> Adobe Systems, Inc.
> http://blogs.adobe.com/aharui
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message