incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnoud Bos <arn...@artim-interactive.nl>
Subject Re: jira task to decide on Apache Flex version number needed
Date Wed, 18 Jan 2012 21:52:50 GMT
yup exactly how i feel about this.

Remember that moving from flex 3 to 4 was a major overhaul. 
And as a result the conversion from flex3 to flex4 of big projects is expensive.
My project leader on the last project was not happy about the time it costed to convert the

big project to the new flex architecture. 

I think the more complex it will be to migrate a flex 4.6 project to the first Apache releases

the more people you will loose.  You would take the risk of  a "nooo not again!!" sentiment
after which
people leave. But if you offer a smooth transition in the first place, fix bugs, offer the
missing components,
optimize... You will keep the people onboard, give them (renewed) confidence
in the Flex project. I think that would be an awesome start of Apache Flex!

On 18-01-2012, at 21:37, Doug McCune wrote:

>> 
>> If we include bug
>> fixes or new features then maybe not.
> 
> 
> One of the reasons for people being optimistic about the move to Apache is
> the opportunity for bugs that people couldn't get Adobe to fix to get
> fixed. To show progress and momentum I'd urge you all to try to fix some
> bugs and get releases out there that people can just drop in, so they'll
> say "Finally, bug XYZ is fixed, thank god this moved to Apache, I see the
> benefit...". If you force everyone to rewrite their apps using the new
> packages throughout you're going to lose those people from your cause.

Met vriendelijke groet,

Arnoud Bos
Artim interactive
T +31 6 246 40 216
E arnoud@artim-interactive.nl




Mime
View raw message