incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Winscot <rick.wins...@gmail.com>
Subject Re: playerglobal.swc version build issue
Date Mon, 23 Jan 2012 16:42:59 GMT
David / Carol,

This is very important... Flash Player 11.2 for Windows will ship with a 'silent background
updater' with Mac OS getting the same feature in the next release.

http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11-2/

What version of Flash Player should we be targeting? The latest release... version skew (
e.g. forward compatibility ) needs to be monitored closely. New features in the Flash Player
may break existing functionality... anyone remember the security changes from v9 -> v10?
Didn't matter what version of the Flex SDK you were using... or what Flash Player version
your app was compiled against. The critical piece was the Flash Player version that was running
your app.  The notion of being able to 'stick with a particular version' of Flash Player in
your enterprise is changing... If you haven't read the Adobe Flash Player Administration Guide
-- it's a great resource. 

http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html

However... as Carol mentions you do "...need to test/certify a release with a particular version."
That is what the -compatibility-version compiler flag is for. 

http://learn.adobe.com/wiki/display/Flex/Backwards+Compatibility+Issues

So... moving forward... the near-term success and stability of Apache Flex will be dependent
upon how well we keep step with Flash Player releases.

Question? Comments? 

-- 
Rick Winscot


On Monday, January 23, 2012 at 10:39 AM, David Arno wrote:

> > From: Rick Winscot [mailto:rick.winscot@gmail.com] 
> > Sent: 23 January 2012 15:27
> > We should be including the latest and greatest swc in our builds... 
> > 
> 
> 
> Why? Surely we should be targeting as old a version of the player as we can. For example,
Flex 4.6 targets Flash player 11.1 and later. Does it really need to? What features changed
in Flex between 4.5 and 4.6 that needed v11 of the player?
> 
> David. 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message