incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Winscot <rick.wins...@gmail.com>
Subject Re: jira task to decide on Apache Flex version number needed
Date Wed, 18 Jan 2012 17:02:55 GMT
I don't see placing requirements on Adobe development flying very far... historically, version
numbers have been used to fix version-specific bugs:

if ( version == SOME_CONSTANT )
{
  // fix a version specific behavior...
}

I haven't seen any of these checks at a point-release or build level. Just something to keep
in mind. 

-- 
Rick Winscot


On Wednesday, January 18, 2012 at 11:49 AM, Omar Gonzalez wrote:

> Perhaps we should try to have some sort of agreement with the Adobe folks
> that would result in reserving the 4.6.x version numbers for any possible
> updates they may need to do to that branch.
> 
> Updates and changes done by Apache that are still based on the 4.x
> architecture should probably fall under 4.7.x, which would retain also the
> original "spark.components..." namespace.
> 
> Then if/when we make major feature additions or architectural changes we
> can move to Flex 5.x, at which point we can revisit the possibility of
> moving the namespace over to "org.apache.flex...".
> 
> Just my initial thoughts.
> 
> -omar 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message