incubator-etch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Holger Grandy (JIRA)" <j...@apache.org>
Subject [jira] Updated: (ETCH-90) Ant Build using ETCH_EXTERNAL_DEPENDS
Date Wed, 15 Sep 2010 10:14:32 GMT

     [ https://issues.apache.org/jira/browse/ETCH-90?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Holger Grandy updated ETCH-90:
------------------------------

    Description: 
change the current build to use ETCH_EXTERNAL_DEPENDS for external dependencies

scripts/antSetup.bat and scripts/antSetup.sh should set all needed environment variables correctly
for Win32 and Linux

currently I have the following stuff in ETCH_EXTERNAL_DEPENDS:

- apache-ant (with apache-ant-dotnet libs installed) in version 1.7.0
- apr in version 1.3.9
- apr-iconv in version 1.2.1
- apr-util in version 1.3.9
- javacc in version 4.0
- cunit in version 2.1.0
- junit in version 4.3.1
- nunit in version 2.4.7
- NSIS in version 2.23
- velocity in version 1.5

inside ETCH_EXTERNAL_DEPENDS, every dependency should have its own directory, versions of
such dependencies should be subdirectories

There should be a "how to build" section on the website describing all this.



  was:
change the current build to use ETCH_EXTERNAL_DEPENDS for external dependencies

scripts/antSetup.bat and scripts/antSetup.sh should set all needed environment variables correctly
for Win32 and Linux

currently I have the following stuff in ETCH_EXTERNAL_DEPENDS:

- apache-ant (with apache-ant-dotnet libs installed) in version 1.7.0
- apr in version 1.3.9
- apr-iconv in version 1.2.1
- apr-util in version 1.3.9
- javacc in version 4.0
- cunit in version 2.1.0
- junit in version 4.3.1
- nunit in version 2.4.7
- NSIS in version 2.46
- velocity in version 1.5

inside ETCH_EXTERNAL_DEPENDS, every dependency should have its own directory, versions of
such dependencies should be subdirectories

There should be a "how to build" section on the website describing all this.




> Ant Build using ETCH_EXTERNAL_DEPENDS 
> --------------------------------------
>
>                 Key: ETCH-90
>                 URL: https://issues.apache.org/jira/browse/ETCH-90
>             Project: Etch
>          Issue Type: Task
>            Reporter: Holger Grandy
>            Assignee: Holger Grandy
>             Fix For: 1.1
>
>
> change the current build to use ETCH_EXTERNAL_DEPENDS for external dependencies
> scripts/antSetup.bat and scripts/antSetup.sh should set all needed environment variables
correctly for Win32 and Linux
> currently I have the following stuff in ETCH_EXTERNAL_DEPENDS:
> - apache-ant (with apache-ant-dotnet libs installed) in version 1.7.0
> - apr in version 1.3.9
> - apr-iconv in version 1.2.1
> - apr-util in version 1.3.9
> - javacc in version 4.0
> - cunit in version 2.1.0
> - junit in version 4.3.1
> - nunit in version 2.4.7
> - NSIS in version 2.23
> - velocity in version 1.5
> inside ETCH_EXTERNAL_DEPENDS, every dependency should have its own directory, versions
of such dependencies should be subdirectories
> There should be a "how to build" section on the website describing all this.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message