incubator-etch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From scott comer <wer...@mac.com>
Subject Re: naming of artifacts...
Date Fri, 22 May 2009 13:42:46 GMT
quoting from:

http://incubator.apache.org/guides/releasemanagement.html


      Naming

Apache releases should contain the full name of the project responsible 
for the release. This ensures that trademark law can be used against 
others issuing artifacts with the same name.

For example, one good name for product bar Apache Foo Project would be 
|apache-foo-bar|.

Once a podling graduations, it should adopt this naming convention. 
Whilst in the incubator, practice is a little different. The release 
name should contain the podling name and may contain apache. Incubator 
policy insists that it must also contain |incubating| (though small 
variations for the sake of readability are usually acceptable).

For example, for podling foo, both |apache-foo-incubating| and 
|foo-incubating| would be acceptable names.

------------------

apache-etch-blah-incubating would seem to be indicated for all our 
artifacts, with etch-blah-incubating being an acceptable alternative. 
i'd rather the version be at the end myself (except for source, where 
you take off .jar and stick on -src.zip.

many projects i've looked at use the blah-ver.jar syntax:

velocity, junit, various ant tasks, commons, dom4j, jakarta, log4j, 
stax, wstx, etc.

the majority have it last when it appears at all.

scott out

James Dixson wrote:
> I think it needs to be 1.1.0-incubating rather than incubating-1.1.0.
>
>
> On Wed, May 20, 2009 at 10:12 AM, scott comer <wert1y@mac.com> wrote:
>   
>> so there was a discussion awhile back about artifact names. since we are
>> trying to get this right in
>> release 1.1...
>>
>> currently we build artifacts named like this:
>>
>>   etch-ant-plugin-1.1.0-src.zip
>>   etch-ant-plugin-1.1.0.jar
>>   etch-compiler-1.1.0-src.zip
>>   etch-compiler-1.1.0.jar
>>   etch-csharp-compiler-1.1.0-src.zip
>>   etch-csharp-compiler-1.1.0.jar
>>   etch-java-compiler-1.1.0-src.zip
>>   etch-java-compiler-1.1.0.jar
>>   etch-java-runtime-1.1.0-src.zip
>>   etch-java-runtime-1.1.0.jar
>>   etch-xml-compiler-1.1.0-src.zip
>>   etch-xml-compiler-1.1.0.jar
>>
>> i'm thinking this needs to be something like this:
>>
>>   etch-ant-plugin-incubating-1.1.0-src.zip
>>   etch-ant-plugin-incubating-1.1.0.jar
>>   etch-compiler-incubating-1.1.0-src.zip
>>   etch-compiler-incubating-1.1.0.jar
>>   etch-csharp-compiler-incubating-1.1.0-src.zip
>>   etch-csharp-compiler-incubating-1.1.0.jar
>>   etch-java-compiler-incubating-1.1.0-src.zip
>>   etch-java-compiler-incubating-1.1.0.jar
>>   etch-java-runtime-incubating-1.1.0-src.zip
>>   etch-java-runtime-incubating-1.1.0.jar
>>   etch-xml-compiler-incubating-1.1.0-src.zip
>>   etch-xml-compiler-incubating-1.1.0.jar
>>
>> right? wrong?
>>
>> scott out
>>
>>
>>     


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message