incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Ivanov <lester.m...@gmail.com>
Subject Re: Actions with Lift 2.2 (was: Move to latest Lift release for 1.2)
Date Sun, 19 Dec 2010 00:37:27 GMT
Awesome work Ethan!

2010/12/18 Ethan Jewett <esjewett@gmail.com>

> This is (I believe) fixed. We were using a MappedLongKey to do a
> lookup in a map but we were storing the value being looked up with a
> key that was just a Long. I guess this doesn't work any more? :-)
>
> Ethan
>
> On Sat, Dec 18, 2010 at 1:03 PM, Richard Hirsch <hirsch.dick@gmail.com>
> wrote:
> > Strange - There is no exception in the log file on stax. .....
> >
> > D.
> >
> > On Sat, Dec 18, 2010 at 1:00 PM, Richard Hirsch <hirsch.dick@gmail.com>
> wrote:
> >> Let me take a look on stax to see if I see anything in the log file.
> >>
> >> D.
> >>
> >> On Sat, Dec 18, 2010 at 12:38 PM, Vladimir Ivanov <
> lester.mail@gmail.com> wrote:
> >>> Hello Ethan,
> >>>
> >>> I just want to say that this action also works locally in trunk for me.
> >>>
> >>> Thank you!
> >>>
> >>> 2010/12/18 Ethan Jewett <esjewett@gmail.com>
> >>>
> >>>> Hi Vassil,
> >>>>
> >>>> Cool, thanks for checking. In case it wasn't clear, Stax is currently
> >>>> on the Lift 2.2 build. It is where I first noticed this problem. If
> >>>> you build trunk locally, I think the action will work (it did for me).
> >>>>
> >>>> Vladimir, no problem with the questions. Ask all you want. We really
> >>>> appreciate it :-)
> >>>>
> >>>> Cheers,
> >>>> Ethan
> >>>>
> >>>> On Fri, Dec 17, 2010 at 11:19 PM, Vassil Dichev <vdichev@apache.org>
> >>>> wrote:
> >>>> > Ethan, I tested both the test and the action, and none seems to
work
> >>>> > on the stax instance. Will check locally.
> >>>> >
> >>>> >
> >>>> > On Fri, Dec 17, 2010 at 6:53 PM, Ethan Jewett <esjewett@gmail.com>
> >>>> wrote:
> >>>> >> I have been able to recreate this problem locally. "every X
min"
> >>>> >> actions simply do not fire on the Lift 2.2 branch. It looks
like
> the
> >>>> >> scheduler never gets started but there are no error messages.
On
> the
> >>>> >> trunk, these types of actions still work fine.
> >>>> >>
> >>>> >> I am going to be pretty busy this weekend and next week, but
I'll
> try
> >>>> >> to look into it. If anyone else has any ideas or wants to try
to
> >>>> >> diagnose the problem, go for it!
> >>>> >>
> >>>> >> Example action that grabs my Jira items and makes them into
> messages:
> >>>> >>
> >>>> >> Test: every 1 mins
> >>>> >> Action: rss:
> >>>>
> http://issues.apache.org/jira/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?pid=12310850&reporterSelect=specificuser&reporter=esjewett&sorter/field=issuekey&sorter/order=DESC&tempMax=1000
> >>>> >>
> >>>> >> Ethan
> >>>> >>
> >>>> >> On Wed, Dec 15, 2010 at 6:52 PM, Ethan Jewett <esjewett@gmail.com>
> >>>> wrote:
> >>>> >>> There is a potential problem with actions. I created some
new Jira
> >>>> >>> items that should be pulled in by my RSS pull action that
runs
> every 5
> >>>> >>> minutes. It's been about 10 minutes and so far I see nothing.
> >>>> >>>
> >>>> >>> Dick, I wonder if you have a chance, can take a look at
the Stax
> logs
> >>>> >>> and see if there is anything within the last 15 minutes
or so? It
> is
> >>>> >>> about 18:45 ECT (17:45 GMT) now, I think. I'm really bad
at
> timezones
> >>>> >>> though, so I might be confused :-)
> >>>> >>>
> >>>> >>> Thanks,
> >>>> >>> Ethan
> >>>> >>>
> >>>> >>
> >>>> >
> >>>> >
> >>>> >
> >>>> > --
> >>>> > Twitter: http://twitter.com/vdichev
> >>>> > Blog: http://speaking-my-language.blogspot.com
> >>>> >
> >>>>
> >>>
> >>>
> >>>
> >>> --
> >>> Best Regards,
> >>> Vladimir Ivanov
> >>>
> >>
> >
>



-- 
Best Regards,
Vladimir Ivanov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message