incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Hirsch <hirsch.d...@gmail.com>
Subject Re: Regarding ESME installation on local
Date Mon, 30 Aug 2010 08:51:05 GMT
try this:

Create a new user via the normal sign-up page. Then go to the
"MyProfile" link and add your openID to that page. No log-off and try
and log-on with your open-id.

Does that work?

D.

On Mon, Aug 30, 2010 at 9:25 AM, Bhardwaj, Gaurav
<gaurav.bhardwaj@sap.com> wrote:
> Hi,
>
> I am facing one issue with deploying ESME on localhost and making it work with yahoo
opened.
>
> I tried using ESME on localhost. I gave the proxy details in the project.props file as
guided in the below mail.
> But still I am not able to make OpenId access with yahoo opened.
>
> I am getting following error.
>
> INFO: Proxy settings: [no host]:[no port]
> INFO - Creating openId auth request.  returnToUrl: https://localhost:8443/ecme/o
> penid/response
> INFO - Starting discovery on URL identifier: https://me.yahoo.com/gaurav11bh
> INFO - Yadis discovery failed on https://me.yahoo.com/gaurav11bh, status: 4, err
> or message: I/O transport error:
> INFO - No OpenID service endpoints discovered through Yadis; attempting HTML dis
> covery...
> INFO - Request /user_mgt/login took 2816 query
> INFO - Service request (POST) /ecme/user_mgt/login took 2822 Milliseconds
> INFO - Service request (GET) /ecme/user_mgt/login took 24 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 2 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 2 Milliseconds
> INFO - Creating openId auth request.  returnToUrl: https://localhost:8443/ecme/o
> penid/response
> INFO - Starting discovery on URL identifier: https://me.yahoo.com/gaurav11bh
> INFO - Yadis discovery failed on https://me.yahoo.com/gaurav11bh, status: 4, err
> or message: I/O transport error:
> INFO - No OpenID service endpoints discovered through Yadis; attempting HTML dis
> covery...
> INFO - Service request (POST) /ecme/user_mgt/login took 10 Milliseconds
> INFO - Service request (GET) /ecme/user_mgt/login took 16 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 3 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 2 Milliseconds
> INFO - Creating openId auth request.  returnToUrl: https://localhost:8443/ecme/o
> penid/response
> INFO - Service request (POST) /ecme/user_mgt/login took 2 Milliseconds
> INFO - Service request (GET) /ecme/user_mgt/login took 19 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 3 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 3 Milliseconds
> INFO - Service request (GET) /ecme/ took 38 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 4 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 2 Milliseconds
> INFO - Creating openId auth request.  returnToUrl: https://localhost:8443/ecme/o
> penid/response
> INFO - Request /comet_request/22C8FA4B06FD33D8FDAE2EA4B5C6604B took 5478 query
> INFO - Starting discovery on URL identifier: https://me.yahoo.com/
> INFO - Service request (GET) /ecme/comet_request/22C8FA4B06FD33D8FDAE2EA4B5C6604
> B took 5479 Milliseconds
> INFO - Yadis discovery failed on https://me.yahoo.com/, status: 4, error message <==============================It
failed when I tried https://me.yahoo.com/ or https://me.yahoo.com/gaurav11bh .
> : I/O transport error:
> INFO - No OpenID service endpoints discovered through Yadis; attempting HTML dis
> covery...
> INFO - Request /user_mgt/login took 2263 query
> INFO - Service request (POST) /ecme/user_mgt/login took 2263 Milliseconds
> INFO - Service request (GET) /ecme/user_mgt/login took 16 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 2 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 2 Milliseconds
> INFO - Creating openId auth request.  returnToUrl: https://localhost:8443/ecme/o
> penid/response
> INFO - Starting discovery on URL identifier: https://me.yahoo.com/
> INFO - Yadis discovery failed on https://me.yahoo.com/, status: 4, error message
> : I/O transport error:
> INFO - No OpenID service endpoints discovered through Yadis; attempting HTML dis
> covery...
> INFO - Service request (POST) /ecme/user_mgt/login took 10 Milliseconds
> INFO - Service request (GET) /ecme/user_mgt/login took 11 Milliseconds
> INFO - Service request (GET) /ecme/classpath/jquery.js took 2 Milliseconds
> INFO - Service request (GET) /ecme/classpath/json.js took 2 Milliseconds
>
>
> Kindly take a look at the log and please let me where I am getting it wrong.
>
> Thanks & Regards,
> Gaurav Bhardwaj
>
> From: Khan, Sameer Ali
> Sent: Friday, August 27, 2010 11:08 PM
> To: Bhardwaj, Gaurav (external)
> Subject: FW: [Les Aventures de Techiemaque...]: ESME installation
>
> FYI
>
> From: Hirsch, Richard [mailto:richard.hirsch@siemens.com]
> Sent: Friday, August 27, 2010 8:14 PM
> To: Khan, Sameer Ali
> Cc: Abesh Bhattacharjee; Anne Katherine Yojana Petteroe
> Subject: AW: [Les Aventures de Techiemaque...]: ESME installation
>
> Hi Sameer,
>
> Here are some tips:
>
> How do you configure OpenID?
>
> Using a proxy with OpenID
>
> Often you may wish to install ESME behind the firewall. In most cases, you won't have
an internal OpenId provider, which means that your users are going to use OpenIds from external
providers. Usually, you will have to go through an internal proxy.
>
> If this is the case, then you must set the proxy server.   Set the paramters in the
default.props file
> http.proxyHost
>
> If you have to access the internet (for example for OpenID support) via a proxy, then
this should be set to the proxy server
>
> empty
>
> http.proxyPort
>
> If you have to access the internet (for example for OpenID support) via a proxy, then
this should be set to the proxy server
>
> empty
>
>
> Look for details here about config files: http://incubator.apache.org/esme/server-configuration.html
>
> If you have further details, you should ask the questions on the esme-dev mailing list.
Details on how to subscribe are here: http://incubator.apache.org/esme/esme-mailing-lists.html
>
>
>
> Thanks.
>
>
>
> D.
>
> ________________________________
> Von: Abesh Bhattacharjee [mailto:aabesh@gmail.com]
> Gesendet: Freitag, 27. August 2010 16:30
> An: Hirsch, Richard; Anne Katherine Yojana Petteroe
> Cc: Sameer
> Betreff: Re: [Les Aventures de Techiemaque...]: ESME installation
> Dear Dick, Anne,
>
> Can you please help Sameer out ?
>
> Sameer,
>
> I'm no longer associated with ESME. But I'm sure Anne & Dick here would be glad to
help you out :)
>
> Warm Regards
> Abesh
>
> PS: Great to see I'm still getting hits for esme on my blog :)
> On Fri, Aug 27, 2010 at 7:57 PM, Sameer <info@abesh.net<mailto:info@abesh.net>>
wrote:
> Hello Abesh,
> I tried installing ESME in my local system - and it got installed, but the problem i
am facing is that - it is looking for an Open ID. I created one, with openid.yahoo.com<http://openid.yahoo.com>
but still am not able to login and use the application.
>
> Could you please help me in installing the application.
>
> Regards,
> Sameer Ali Khan
>
> cc_me: Y
>
>

Mime
View raw message