incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vassil Dichev <vdic...@apache.org>
Subject Re: More Compile Errors
Date Thu, 03 Jun 2010 19:59:23 GMT
No sooner than you've written your mail, David has assigned the
ticket. I don't expect it to take much considering the working version
was there before the refactoring.

On Thu, Jun 3, 2010 at 10:36 PM, Richard Hirsch <hirsch.dick@gmail.com> wrote:
> Thanks for finding out what the problem is.
>
> Let's see how @dpp and the rest of the Lift team responds
>
> D.
>
> On Thu, Jun 3, 2010 at 9:00 PM, Vassil Dichev <vdichev@apache.org> wrote:
>> There, I've debugged the issue to a refactoring in Lift and submitted a ticket:
>>
>> https://www.assembla.com/spaces/liftweb/tickets/544-testframework-throws-nullpointerexception-on-empty-body
>>
>>
>> On Thu, Jun 3, 2010 at 8:18 AM, Vassil Dichev <vdichev@apache.org> wrote:
>>> It seems that whenever empty content is expected, a
>>> NullPointerException is thrown in the Lift helpers, because the whole
>>> input stream is null. I'll try and see in the next days if this is
>>> something that needs to be fixed in Lift or just the test mocks (which
>>> were heavily refactored the last couple of days).
>>>
>>>
>>> On Tue, Jun 1, 2010 at 4:01 PM, Vassil Dichev <vdichev@apache.org> wrote:
>>>> Very possible, I noticed this too, but didn't have time to
>>>> investigate. I'll find the last working build and check the changes.
>>>>
>>>>
>>>> On Tue, Jun 1, 2010 at 3:29 PM, Richard Hirsch <hirsch.dick@gmail.com>
wrote:
>>>>> We now get some strange test failures - they are associated with GETs
>>>>> instead of posts.
>>>>>
>>>>> Could there be a link with changes in the Lift Testkit?
>>>>>
>>>>> Tests in error:
>>>>>  API2 should /user/messages GET when no new messages exist, returns
>>>>> 204 (no content)
>>>>>  API2 should /user/messages?timeout=2 GET when no new messages exist,
>>>>> returns 204 (no content)
>>>>>  API2 should /pools/POOLID/messages GET with valid session and new messages
>>>>>  API2 should /pools/POOLID/messages GET when no new messages exist,
>>>>> returns 204 (no content)
>>>>>  API2 should /pools/POOLID/messages?timeout=2 GET with valid session
>>>>>  API2 should /pools/POOLID/messages?timeout=2 GET when no new
>>>>> messages exist, returns 204 (no content)
>>>>>
>>>>>
>>>>> On Tue, Jun 1, 2010 at 1:36 PM, Richard Hirsch <hirsch.dick@gmail.com>
wrote:
>>>>>> Thanks - this fixed the problem
>>>>>>
>>>>>> On Tue, Jun 1, 2010 at 11:53 AM, Vassil Dichev <vdichev@apache.org>
wrote:
>>>>>>> I've committed a fix, try it now please.
>>>>>>>
>>>>>>> It should be easy to modify if there's a more elegant solution
to this problem.
>>>>>>>
>>>>>>> Vassil
>>>>>>>
>>>>>>>
>>>>>>> On Tue, Jun 1, 2010 at 11:53 AM, Vassil Dichev <vdichev@apache.org>
wrote:
>>>>>>>> Due to a refactoring it seems that now the type inferencer
cannot put
>>>>>>>> the right implicit and we must provide it a type hint. One
possible
>>>>>>>> fix is for all get and post methods to be replaced with:
>>>>>>>>
>>>>>>>> get[Response]
>>>>>>>> post[Response]
>>>>>>>>
>>>>>>>> I'll try to submit a fix soon.
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, May 31, 2010 at 2:22 PM, Richard Hirsch <hirsch.dick@gmail.com>
wrote:
>>>>>>>>> We are currently experiencing some errors during our
compile.
>>>>>>>>>
>>>>>>>>> I think it is assocaited with changes in the lift Testkit.
>>>>>>>>>
>>>>>>>>> I've tried to find a solution but haven't been successful.
Can
>>>>>>>>> somebody else take a look and see if they spot the problem.
>>>>>>>>>
>>>>>>>>> D.
>>>>>>>>>
>>>>>>>>> [INFO] Compiling 7 source files to
>>>>>>>>> /export/home/hudson/hudson-slave/workspace/ESME/server/target/test-classes
>>>>>>>>> [WARNING] /export/home/hudson/hudson-slave/workspace/ESME/server/src/test/scala/org/apache/esme/api/ApiTest.scala:84:
>>>>>>>>> error: no implicit argument matching parameter type (String,
>>>>>>>>> org.apache.commons.httpclient.HttpClient,
>>>>>>>>> org.apache.commons.httpclient.HttpMethodBase) => T
was found.
>>>>>>>>> [WARNING] login <- post("/api/login", "token" ->
token) !@ "Failed to
>>>>>>>>> log in" if (testSuccess(login))
>>>>>>>>> [WARNING] ^ [WARNING]
>>>>>>>>> /export/home/hudson/hudson-slave/workspace/ESME/server/src/test/scala/org/apache/esme/api/API2Test.scala:51:
>>>>>>>>> error: no implicit argument matching parameter type (String,
>>>>>>>>> org.apache.commons.httpclient.HttpClient,
>>>>>>>>> org.apache.commons.httpclient.HttpMethodBase) => Nothing
was found.
>>>>>>>>> [WARNING] val post_session = post("session", "token"
-> token)
>>>>>>>>>  [WARNING] ^ [WARNING]
>>>>>>>>> /export/home/hudson/hudson-slave/workspace/ESME/server/src/test/scala/org/apache/esme/api/API2Test.scala:94:
>>>>>>>>> error: no implicit argument matching parameter type (String,
>>>>>>>>> org.apache.commons.httpclient.HttpClient,
>>>>>>>>> org.apache.commons.httpclient.HttpMethodBase) => T
was found.
>>>>>>>>> [WARNING] session <- post("session", "token" ->
"000000") [WARNING] ^
>>>>>>>>> [WARNING]
>>>>>>>>>  three errors found
>>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message