incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anne Kathrine Petterøe <yoji...@gmail.com>
Subject Re: Can we close ESME-175?
Date Wed, 07 Apr 2010 13:27:56 GMT
What exactly does this line do?
Is it something we can remove or do we need to find a workaround?

/Anne


On 7. apr. 2010, at 13.31, Richard Hirsch wrote:

> The problem is this line in display_messages.js:
> 
>      var msgBody = jQuery(cometMsg.text).find('body').html();
> 
> This code doesn't work in IE6 and returns an empty string.
> 
> D.
> 
> On Tue, Apr 6, 2010 at 11:31 AM, Anne Kathrine Petterøe
> <yojibee@gmail.com>wrote:
> 
>> Yes.
>> 
>> On 6. apr. 2010, at 11.29, Richard Hirsch wrote:
>> 
>>> On Tue, Apr 6, 2010 at 11:19 AM, Anne Kathrine Petterøe
>>> <yojibee@gmail.com>wrote:
>>> 
>>>> I have the same problems locally.
>>> 
>>> 
>>> By same problem, do you mean that you see the message attributes but not
>> the
>>> message text?
>>> 
>>> 
>>> 
>>>> In all IE versions (6/7/8). It works locally and on stax with firefox.
>>>> 
>>>> /Anne
>>>> 
>>>> 
>>>> On 6. apr. 2010, at 11.13, Richard Hirsch wrote:
>>>> 
>>>>> Do you have the same problem locally with IE? Do you see the message
>>>> text?
>>>>> 
>>>>> D.
>>>>> 
>>>>> On Tue, Apr 6, 2010 at 10:56 AM, Anne Kathrine Petterøe
>>>>> <yojibee@gmail.com>wrote:
>>>>> 
>>>>>> I agree it is strange. I didn't work on message.html a week ago.
>>>>>> Did you?
>>>>>> 
>>>>>> /Anne
>>>>>> 
>>>>>> 
>>>>>> On 6. apr. 2010, at 10.53, Richard Hirsch wrote:
>>>>>> 
>>>>>>> The problem exists on http://esmecloudperf.esme.staxapps.net/
which
>> is
>>>>>> still
>>>>>>> based on the deployment from a week ago.
>>>>>>> 
>>>>>>> Although I see some message attributes but not the message itself.
>>>>>>> 
>>>>>>> Strange.
>>>>>>> 
>>>>>>> D.
>>>>>>> 
>>>>>>> On Mon, Apr 5, 2010 at 6:24 PM, Ethan Jewett <esjewett@gmail.com>
>>>> wrote:
>>>>>>> 
>>>>>>>> As Dick mentioned, I did edit the mail timeline template
to force
>>>>>>>> messages to wrap. You may want to try reverting my change
to that
>>>>>>>> template file to see if it starts working.
>>>>>>>> 
>>>>>>>> Ethan
>>>>>>>> 
>>>>>>>> On Mon, Apr 5, 2010 at 11:36 AM, Anne Kathrine Petterøe
>>>>>>>> <yojibee@gmail.com> wrote:
>>>>>>>>> It works in FF and I can't remember last time I saw it
working in
>> IE.
>>>>>>>>> I see it in both the public and my timeline.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> On 5. apr. 2010, at 17.33, Richard Hirsch wrote:
>>>>>>>>> 
>>>>>>>>>> Hope it wasn't the shift in the message.html file
to "divs" away
>>>> from
>>>>>>>>>> <table> elements.
>>>>>>>>>> 
>>>>>>>>>> D.
>>>>>>>>>> 
>>>>>>>>>> On Mon, Apr 5, 2010 at 4:35 PM, Anne Kathrine Petterøe
<
>>>>>>>> yojibee@gmail.com>wrote:
>>>>>>>>>> 
>>>>>>>>>>> Already tried that, and it didn't to the trick
for me.
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> On 5. apr. 2010, at 16.31, Sig Rinde wrote:
>>>>>>>>>>> 
>>>>>>>>>>>> Browser cache... hint hint?
>>>>>>>>>>>> 
>>>>>>>>>>>> 
>>>>>>>>>>>> On 5 April 2010 15:26, Anne Kathrine Petterøe
<
>> yojibee@gmail.com>
>>>>>>>> wrote:
>>>>>>>>>>>>> I now have a different problem.
>>>>>>>>>>>>> I don't see any of the messages in my
timeline in any IE
>> browser.
>>>>>>>> Seems
>>>>>>>>>>> to work on FF.
>>>>>>>>>>>>> Can anyone else confirm this?
>>>>>>>>>>>>> 
>>>>>>>>>>>>> 
>>>>>>>>>>>>> On 4. apr. 2010, at 19.41, Richard Hirsch
wrote:
>>>>>>>>>>>>> 
>>>>>>>>>>>>>> If you want to fix the problem, go
to User.scala - "genform"
>>>>>>>> function -
>>>>>>>>>>>>>> approx. line 114 and change "submit"
-%> to "submit"  _id_>
>>>>>>>>>>>>>> 
>>>>>>>>>>>>>> D.
>>>>>>>>>>>>>> 
>>>>>>>>>>>>>> On Sun, Apr 4, 2010 at 1:13 PM, Richard
Hirsch <
>>>>>>>> hirsch.dick@gmail.com
>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>> The problem is that the redirect
isn't coming on IE6. I don't
>>>>>> know
>>>>>>>> why
>>>>>>>>>>> yet.
>>>>>>>>>>>>>>> It works on FF but not on IE6.
I'm trying to find out if
>> there
>>>>>> are
>>>>>>>>>>> errors
>>>>>>>>>>>>>>> that don't bubble up to the UI.
>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>> D.
>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>> On Sat, Apr 3, 2010 at 7:34 PM,
Richard Hirsch <
>>>>>>>> hirsch.dick@gmail.com
>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>> I have IE6 on my laptop I'll
take a look as well.
>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>> D.
>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>> On Sat, Apr 3, 2010 at 7:03
PM, Anne Kathrine Petterøe <
>>>>>>>>>>> yojibee@gmail.com
>>>>>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>> The signup error is an
IEx error, not specifically to IE7.
>>>>>>>>>>>>>>>>> I have tried IE6, IE7
and IE8 today and get the same error
>> on
>>>>>> all
>>>>>>>>>>>>>>>>> machines.
>>>>>>>>>>>>>>>>> The toolbar doesn't say
anything, to me it just looks like
>> it
>>>>>>>> does a
>>>>>>>>>>> page
>>>>>>>>>>>>>>>>> refresh when I hit the
signup button.
>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>> On 3. apr. 2010, at 18.59,
Richard Hirsch wrote:
>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>> Does the toolbar
say why the sign-up doesn't work? Have
>> you
>>>>>>>> tried
>>>>>>>>>>> it
>>>>>>>>>>>>>>>>> with
>>>>>>>>>>>>>>>>>> HTTPWatch in IE7?
>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>> On Sat, Apr 3, 2010
at 5:51 PM, Anne Kathrine Petterøe <
>>>>>>>>>>>>>>>>> yojibee@gmail.com>wrote:
>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> Hi,
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> Can we close
the issue ESME-175 "IE7 doesn't work at all
>>>> with
>>>>>>>> new
>>>>>>>>>>>>>>>>> layout".
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> IE7 does by definition
work with the new layout, it is
>> lift
>>>>>>>>>>> specific
>>>>>>>>>>>>>>>>> coding
>>>>>>>>>>>>>>>>>>> which breaks
the design.
>>>>>>>>>>>>>>>>>>> So far to fix
the IE7 issues I have had to do changes in
>>>> the
>>>>>>>> html
>>>>>>>>>>>>>>>>> files,
>>>>>>>>>>>>>>>>>>> not in the CSS.
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> I would like
to suggest that everyone who works on the UI
>>>>>>>>>>> currently
>>>>>>>>>>>>>>>>> (and
>>>>>>>>>>>>>>>>>>> are on PCs or
have access to one) uses IETester
>>>>>>>>>>>>>>>>>>> http://my-debugbar.com/wiki/IETester/HomePage
to check
>>>> which
>>>>>>>>>>> changes
>>>>>>>>>>>>>>>>> are
>>>>>>>>>>>>>>>>>>> breaking the
layout. That way it will be easier to track
>>>> down
>>>>>>>> the
>>>>>>>>>>>>>>>>> culprit
>>>>>>>>>>>>>>>>>>> later.
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> /Anne
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>> 
>>>>>>>>>>>>> 
>>>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>> 
>>>>>> 
>>>>>> 
>>>> 
>>>> 
>> 
>> 


Mime
View raw message