incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ethan Jewett <esjew...@gmail.com>
Subject Re: Current version on Stax
Date Sat, 20 Mar 2010 19:43:33 GMT
Fix is checked in, and I also noticed that Hudson didn't seem to be
building due to some sort of Maven issue (IOException?) so I switched
the Maven version used by Hudson from "latest" to 2.2 and now it seems
to work.

Ethan

On Sat, Mar 20, 2010 at 12:45 PM, Ethan Jewett <esjewett@gmail.com> wrote:
> Ok, I think I've got it.
>
> The reason appears to be the regular action I have set up to pull my
> Twitter feed puts a message into my user's mailbox. This message is
> never displayed in the timeline. However, these messages, inserted
> into my mailbox every 5 minutes, have the affect of pushing other
> messages out of my mailbox. It takes 5*40 = 200 minutes for 40 of
> these non-displayed messages to build up in my mailbox and push out
> all other messages.
>
> I have now verified this locally (it goes faster if you set up a bunch
> of regular actions (every 1 mins)) and I will create a JIRA issue and
> patch. My patch strategy is going to be to never add messages to the
> mailbox when they have a message ID of -1, which seems to be the
> convention for regular actions.
>
> Ethan
>
> On Sat, Mar 20, 2010 at 10:05 AM, Richard Hirsch <hirsch.dick@gmail.com> wrote:
>> It is strange - I saw one of the messages from your private pool on the
>> public streams page a while back.
>>
>> There are other users who use twitter feeds as well. Maybe it is the filter
>> on the twitter stream
>>
>> D.
>>
>> On Sat, Mar 20, 2010 at 4:07 PM, Ethan Jewett <esjewett@gmail.com> wrote:
>>
>>> No, I can't reproduce the problem locally. Everyone else's timelines
>>> seem to be working fine, so it must be something specific to what I
>>> have configured. Either a rogue action on the server, or something I
>>> have done is causing a bug to show up.
>>>
>>> Currently, I don't really have anything complicated set up on the server:
>>>
>>> 1 action to pull my Twitter feed every 5 minutes and post messages
>>> containing the words "esme" or "sap" to the ESME instance
>>>
>>> 2 pools - one private test one, and one ESME team pool
>>>
>>> As far as I can tell, that's it. I'll see if I can access the Stax
>>> database later today to see if there might be any actions specific to
>>> me that I can't see in the web ui.
>>>
>>> Ethan
>>>
>>> On Fri, Mar 19, 2010 at 10:44 PM, Richard Hirsch <hirsch.dick@gmail.com>
>>> wrote:
>>> > The trunk. The UI branch doesn't exist amy more.
>>> >
>>> > can you reproduce the problem locally?
>>> >
>>> > On Fri, Mar 19, 2010 at 10:25 PM, Ethan Jewett <esjewett@gmail.com>
>>> wrote:
>>> >
>>> >> This one is probably for Dick, but in case someone else can answer:
>>> >>
>>> >> Is the current ESME deployment on the Stax instance based on trunk or
>>> >> from the UI branch? I ask because I still have my timeline issue. I
>>> >> have my fingers crossed that it's not from trunk yet :-)
>>> >>
>>> >> Ethan
>>> >>
>>> >
>>>
>>
>

Mime
View raw message