incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Hirsch <hirsch.d...@gmail.com>
Subject Re: Broken OpenID
Date Sun, 06 Dec 2009 23:07:51 GMT
Just committed the change but we need to get the edit profile working again.

D.

On Wed, Dec 2, 2009 at 3:32 PM, Richard Hirsch <hirsch.dick@gmail.com> wrote:
> Haven't added this patch yet.  Friday....
>
> Re sign on problem: Strange I didn't see any errors. try a different
> userid you already might be in the system
>
>
>
> On Wed, Dec 2, 2009 at 3:01 PM, Ethan Jewett <esjewett@gmail.com> wrote:
>> Is there any thinking around whether or not we should apply this
>> patch, at least temporarily?
>> (https://issues.apache.org/jira/browse/ESME-111)
>>
>> I ask the question because I also can't create a user on the
>> performance test instance of ESME, but I should be able to use an
>> OpenID, maybe...
>>
>> Ethan
>>
>> On Sat, Nov 28, 2009 at 5:08 PM, Anne Kathrine Petterøe
>> <akpetteroe@gmail.com> wrote:
>>> Wow, thank you for taking care of this so quickly!
>>>
>>> BTW does anyone know what happened to the user-edit page?
>>>
>>> /Anne
>>>
>>>
>>> On 28. nov. 2009, at 22.20, Ethan Jewett wrote:
>>>
>>>> Alrighty, I posted a patch to the Jira item that makes it work in kind
>>>> of a hackish way (nickname of users created from openId *is* the
>>>> openId itself). However, I think the real fix for this is getting the
>>>> user mgmt interface working again. Once that's fixed, I'm pretty sure
>>>> my patch can be unapplied and it'll just start working like in the
>>>> good old days.
>>>>
>>>> Ethan
>>>>
>>>> On Sat, Nov 28, 2009 at 3:11 PM, Ethan Jewett <esjewett@gmail.com>
wrote:
>>>>>
>>>>> I'm looking at fixing this now. Not going to be pretty (we need a
>>>>> user-edit view working again to make it work right), but I can get it
>>>>> working.
>>>>>
>>>>> Ethan
>>>>>
>>>>> On Sat, Nov 28, 2009 at 2:35 PM, Richard Hirsch <hirsch.dick@gmail.com>
>>>>> wrote:
>>>>>>
>>>>>> I did some work on the problem last night and localized the problem
>>>>>> (all my "research" is in comments in the Jira item) but I have no
idea
>>>>>> why it occurs. I just don't have enough knowledge about lift to know
>>>>>> why it doesn't work :-<
>>>>>>
>>>>>>  It is on David's list but I don't know when he'll get around to
it.
>>>>>>
>>>>>> I think Anne is right and we should remove it until it works.
>>>>>>
>>>>>> D.
>>>>>>
>>>>>> On Sat, Nov 28, 2009 at 9:09 PM, Markus Kohler <markus.kohler@gmail.com>
>>>>>> wrote:
>>>>>>>
>>>>>>> Hi Anne,
>>>>>>> Makes sense to me.
>>>>>>> Markus
>>>>>>> "The best way to predict the future is to invent it" -- Alan
Kay
>>>>>>>
>>>>>>>
>>>>>>> On Sat, Nov 28, 2009 at 9:03 PM, Anne Kathrine Petterøe <
>>>>>>> akpetteroe@gmail.com> wrote:
>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> We have had many trying out ESME this last week.
>>>>>>>> Dick and I have picked up several new users on twitter who
all tried
>>>>>>>> to
>>>>>>>> sign up with the currently broken OpenID sign on.
>>>>>>>> I feel it gives a very bad impression of ESME to have something
which
>>>>>>>> doesn't work already on the sign on page.
>>>>>>>>
>>>>>>>> I will remove the OpenID field in new UI until someone has
fixed the
>>>>>>>> problem, unless someone objects of course.
>>>>>>>>
>>>>>>>> /Anne
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>
>>>
>>
>

Mime
View raw message